[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: .xsession problem



Jim Seymour wrote:
> Running Debian Etch on an AMD Athalon box with all the current updates.
> I have tried to no avail to get a .xsession file to launch pland (Plan
> Daemon) when I log into my box. The file is executable and
> allow-user-xsession is set in /etc/X11/Xsession.options. The contents of
> the .xsession are:
> 
> exec pland (I have tried it with and without exec)

The exec will overlay and replace the currently running shell with the
listed command.  Usually that would be a window manager.  Is pland a
window manager?

If you want to start additional programs you should put them in the
background.

  pland &

The .xsession file is used by xdm/kdm/gdm.  I am hoping that you also
included a #!/bin/bash --login line and also a line that starts your
window manager.

  #!/bin/bash --login
  pland &
  exec x-session-manager
  #exec fvwm2
  #exec startkde
  #exec gnome-session

If you are using 'startx' or simply 'xinit' then you would use the
~/.xinitrc file with different contents instead.

Bob

Attachment: signature.asc
Description: Digital signature


Reply to: