[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't recover sound

Hi Victor,

On Wed, Sep 07, 2005 at 12:37:35PM +0900, Victor Munoz wrote:
> Hello.
> Sometimes I can't hear any sound (xmms, mplayer, play), getting things like
> 'Device or resource busy'. This happened in woody, now in sarge, sometimes
> in sid, and everytime it happens, I do a Google search to try to find a
> solution smarter than rebooting, but never find an answer, so I have to
> reboot.
> So the question is: How can I recover sound in this situation? Yesterday it
> happened, for instance. There was no xmms, mplayer, play, skype, realplay or
> whatever I could remember involving sound running in the background. I don't
> run esd. But still, I could not play any movie or hear any sound from xmms.
> I tried removing/reloading sound modules, but everytime I tried, it
> complained that the module is being used and cannot be removed. There
> doesn't seem to be a rmmod -f option.

So you did 'ps aux' and checked for possibly existing processes, did you?
Another tool might be lsof, but I'm not sure how to use it.
You could also try to remember which was the last sound program you used before
the problem came.
> Is there a way to know which program is using the sound modules, so 
> I can kill that, or any other way to recover a 'clean sound state' without
> rebooting? There should be, but Google has not been my friend, probably for
> my inability to make the right question.
> Regards,
> 					Victor

Joachim Fahnenmüller

Reply to: