[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrade from python2.3 to python2.4

Dom wrote:
> Hello,
> I downloaded a game sudoku recently but I'm having troubles installing
> it. It requires Python 2.4 or higher and when I downloaded it first
> Python 2.3 was on my system. So I searched in aptitude if I can
> upgrade it and I found Python 2.4 - so I installed it. Tried to
> install the sudoku application but a message
> Error: Python-2.4 or newer is required. Current version:
>  2.3.5 (#2, Jun 19 2005, 13:28:00)
> [GCC 3.3.6 (Debian 1:3.3.6-6)]
> comes out.So I'm not sure what exactly to do in order to upgrade from
> Python2.3 to Python2.4. I thought I could delete Python2.3 package
> once I had installed Python2.4 but I'm afraid to pursue with this

I am not sure if I understand what you have done. If you have
two python versions installed (python2.3 and python2.4) then
you could start your game with the python version you like, e.g.:

python2.4 sudoku

    I hope this helps.

> since I get many broken packages then and gnome-desktop-environment
> depends on Python2.3 so I really don't want to play with my desktop
> environment (GNOME, X Window server), I don't know, I'm not very sure
> about these things as I have had a nightmare setting up my desktop
> environment and I really depend on it if you know what I mean.
> I would appreciate any help you can give.
> Thank you,
> Dom

Reply to: