[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How do I get a /dev/fb0 from my Hercules Kyro?

Hendrik Boom wrote:
On Fri, Jul 29, 2005 at 01:42:51PM +0100, Wackojacko wrote:

I'm one of those poor wretches with a Hercules Prophet Kyro
PCI video card on an aging 233 MHz Pentium. the one that isn't
VESA, or even VGA, but EGA (remember those?). I found a report
dated 2002 that someone got such a setup to work with
the framebuffer driver fbdev (though of course no acceleration)
and tried configuring my x server accordingly.
All went well, until, when I ran startx, the message

(EE) open /dev/fb0: No such device

Of course there is a /dev/fb0 *file*.  Presumably I am missing
some kernel option or module that would actually *implement*
the behaviout of this device.  Anyone know where to find it?

Now I'm pretty sure that *someone*, *somewhere* knows how to
make these cards work at least a little:  when I had Mandrake on
the machine, it did a pretty graphic display durung boot time,
but when it finished booting, it switched to a text console,
and I never managed to get X to work.  It was frustrating not to
get the level of performance out of it that the boot-up display

-- hendrik

Have you checked the permissions on the dev/fb0 file. I had a similar problem with /dev/input/js* and it turned out to have the wrong permissions (600 instead of 660).

ls -l /dev/fb0 gives:

crw-rw----  1 root video 29, 0 2005-07-09 07:03 /dev/fb0

And I checked -- I am a member of the video group.
So I suspect the /dev file is OK, but I am missing some kernel driver.
Is there any documentation anywhere which drivers support which /dev files?

This machine could be a decent X-terminal (ceratinly better than the one
I used at work fifteen years ago) if I could only get this frame buffer
to work.

-- hendrik

Are you using udev?
Did you loaded the correct module for your framebuffer?


Reply to: