[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

SATA problems

I have a Shuttle ST205G, with 2 x 80GB SATA drives in it. I have
confidence in the hardware, when installed with Windows, even the SATA
RAID (ULi M5287) works fine (F6 to load Raid Driver)

However, with Debian (Sarge) I get as far as trying to set up
partitions, and no disks can be seen by the installer. I've tried with
SATA RAID disabled in BIOS, so there are just 2 SATA drives there,
whcih I would "Software" RAID if I could see them, and I've tried with
the BIOS RAID (1) enabled, which presents the RAID array as a SCSI
interface, but in both cases I cannot see the disks.

I believe SATA support was included in the kernel from 2.6.10, but even
when I try to install with a 2.6 kernel and the NetBoot disk, it fails.

I think I need to add some drivers, etc to the kernel, but I'm not
confident (on what is needed *or* how to do it!). I've googled around
for a couple of days, and everything points in this direction, but I
need to be sure before I hack round and create a bigger problem than I
already have.

Reply to: