[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Need Help-YMF724F Sound Card And ALSA



<posted & mailed>

Leonard Chatagnier wrote:

> Have tried for several weeks to get sound from my Dell Dimensions XPS
> T450 with YMF724F sound
> card and ALSA drivers.  Have posted before on this issue with no
> solution forthcoming.  My latest

I used to have a Dell XPS T450 with YMF724 sound, and it worked perfectly. 
So it's possible.

> effort followed the instructions at
> www.alsa-project.org/alsa-doc/doc-php/template.php?module=ymfpci#opt
> with no resulting sound from my pc.  Using alsamixer, I unmuted all and
> set volume controls up to
> 90% on everything; still no sound.  Googling yielded lots of hits but
> nothing useful except the above
> URL.  I'm using real player 10 GOLD and can play video news clips from
> Reuters and API on MyYahoo
> with good video output but no sound.  I do get static from my speakers
> after setting the alsamixer so I'm
> confident the speakers are wording.  ymfpci module is loaded.  I ran
> update-modules after following the instructions at the above URL.
> Hopefully someone using the YMF724F card can tell me what is wrong and
> how to fix it, but would appreciate any help whatsoever.  My ALSA
> related modules.conf is listed below:
> NOTE: Not subscribed-PLEASE COPY MY EMAIL ADDRESS.
[snip modules config]
> I also tried to set up the*_The .asoundrc file__
> _as shown in the above URL but am not familar with the vi command and
> couldn't figure how to
> save it.  I just closed the terminal and cated the .swp file which was a
> binary an appeared to have
> the copied data in it.  However, I don't think the .asoundrc file should
> have an .swp extension.
> Read man vi, but didn't understand it.  Again, I'd appreciate any help
> resolving this issue.
> Thanks,
> Len Chatagnier
> *

To save in vi, first you need to enter command mode by hitting the escape
key.  Then, type :wq and hit return (<colon>wq<return>)  The binary .swp
file is how vi tracks the changes that you've made to the file.  It's not
going to be sufficient to copy the .swp file to the destination file. 
However, the .swp file is there to save your edits, should vi crash for any
reason.  In that case, just vi the file again (not the swap file, the
original file), and vi will ask you if you want to recover your changes
from a previous session.

Anyway, on to your problem.  Did you run aslaconf?  That should be able to
set up your sound card for you.  You will then need to run alsamixer to
unmute the channels. 

You mention that you've been using real player to test the sound.  How about
using something a little more basic, like a command line utility (play, for
example).  That might give you a more meaningful error message.

Are you using a sound daemon, like arts or esd?  If so, is real player
configured to play through the sound daemon?  If not, you may have problems
due to the device being locked by the sound server.

Post the sound related output of lsmod, and post the attempts at playing
sound with a command line utility, and that should help pinpoint the
problem.

Justin Guerin




Reply to: