[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: IPW2100


I'm still not getting this, perhaps I'm missing something. Here's what I'm doing

aptitude install ipw2100 wireless-tools

BTW I also downloaded the firmware for .55 and later and unzip them to

cd /usr/src
tar zxvf ipw2100-source.tar.gz
module-assistant a-i ipw2100

I select the follow under wireless
ipw2100, ieee80211_crypt, ieee80211_cryp_wep, ieee80211
then exit

lsmod produces
ipw2100                        150988  0 
ieee80211_crypt_wep   5380  0 
crc32                             4416  1 ieee80211_crypt_wep
firmware_class              10112  1 ipw2100
ieee80211                     40612  1 ipw2100
ieee80211_crypt           5832  3 ipw2100,ieee80211_crypt_wep,ieee80211

I'm thinking I'm ok but... iwconfig produces
lo        no wireless extensions.
eth0      no wireless extensions.
eth1      no wireless extensions.
sit0      no wireless extensions.

Any attempt to load essid in the iwconfig produces
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device eth1 ; Operation not supported.

my interfaces is like
iface eth1 inet dhcp
	wireless_essid something
	wireless_mode managed

please help

On Mar 27, 2005 9:07 AM, Ritesh Raj Sarraf
<riteshsarraf@users.sourceforge.net> wrote:
> paul tsai wrote:
> > Hello all,
> >
> > I´ve been trying out debian again after a brief period of not using it
> > for a while and for some reason, things definitely seem broken in
> > sarge, but I´m sure everyone will say it´s me.
> >
> > I used to remember that the network config scripts were in
> > /etc/sysconfig/network-scripts.  When were they changed to
> > /etc/network?  In any case I ran into a couple of issues, but the one
> > that´s making me upset that I for the life of me cannot figure out how
> > to setup my wireless in debian (it works easily in other  distros).
> >
> > I have a Intel 2100 and I´m using Sarge.  So I installed the source
> > through sarge and followed the directions in /usr/share/doc/ipw2100,
> > untarring the files necessary and running module assistant which comes
> > back with no errors.  So I then go do the firmware and I think that´s
> > good too.  so reboot, and I dmesg and I see that the modules are
> > loading (BTW I did have the wireless support in my kernel enabled),
> > but for the life of me I cannot get it to assign it to a device like
> > wlan0.  Anytime I do anything that tries to setup the network I get a
> > device not found etc.  Now I´m assigning it an alias in both
> > modutils/alias and modprobe.d/alias and putting ipw2100 in the modules
> > files.  Either I´m missing something or something is broken.  Please
> > help.  I haven even began to try to setup the network connections.
> >
> As soon as the firmware and modules for ipw2100 is loaded it get an ethernet
> device name attached to it. Something like ethX. I've been using it well
> for a couple of months now.
> rrs
> --
> Ritesh Raj Sarraf
> RESEARCHUT -- http://www.researchut.com
> Gnupg Key ID: 04F130BC
> "Stealing logic from one person is plagiarism, stealing from many is
> research".
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


Email - paultsai@gmail.com

"And i think it's gonna be a long long time
Till touch down brings me round again to find
I'm not the man they think i am at home"
Rocket Man - Bernie Taupin

Reply to: