[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Modules_install error

Thanks a lot Gene for help.

I did it all over again and ran make oldconfig this
time. Still i am getting errors.(fewer now )

make[1]: Entering directory
make[1]: Nothing to be done for `modules_install'.
make[1]: Leaving directory
cd /lib/modules/2.4.29; \
mkdir -p pcmcia; \
find kernel -path '*/pcmcia/*' -name '*.o' | xargs -i
-r ln -sf ../{}
if [ -r System.map ]; then /sbin/depmod -ae -F
System.map  2.4.29; fi
depmod: /opt/Xilinx6.3/bin/lin/wdreg is not an ELF
depmod: /opt/Xilinx6.3/bin/lin/install_drv is not an
ELF file
depmod: *** Unresolved symbols in
depmod:         usb_ifnum_to_if_Rsmp_7f504340
depmod:         usb_alloc_urb_Rsmp_37eb1efb
depmod:         usb_register_Rsmp_6ab484a9
depmod:         usb_set_interface_Rsmp_fc4b0efa
depmod:         usb_clear_halt_Rsmp_3b248300
depmod:         usb_deregister_Rsmp_a38a432d
depmod:         usb_submit_urb_Rsmp_87e0f069
depmod:         usb_free_urb_Rsmp_986294e5
depmod:         usb_unlink_urb_Rsmp_1a73da9d
make: *** [_modinst_post] Error 1

I think i will try downloading tar.gz again(i had bz2)
and maybe i should try the latest 2.4.30 instead of

Thanks anyways.

--- Gene Heskett <gene.heskett@verizon.net> wrote:
> On Wednesday 06 April 2005 08:07, RituRaj wrote:
> >Hi all;
> >
> >I am compiling 2.4.29 on redhat 9( i am sorry for
> >asking the question here). I am simply copying the
> >config file of 2.4.20-8(redhat default) as .config
> in
> >my source dir of 2.4.29.
> Did you, after copying those .configs in, do a 'make
> oldconfig'?
> This is a utility built into the Makefile that
> allows the differences 
> in how things are done to be incorporated into a
> newer .config.  It 
> may ask you some questions in order to do that.
> >The compilation has been successful on 2 machines.
> I'm amazed that it worked at all.
> >However on one machine it gives error in "make
> >modules_install"
> >
> >depmod: /opt/Xilinx6.3/bin/lin/wdreg is not an ELF
> >file
> >depmod: /opt/Xilinx6.3/bin/lin/install_drv is not
> an
> >ELF file
> >depmod: *** Unresolved symbols in
> >/lib/modules/2.4.29custom1/kernel/crypto/autoload.o
> >depmod:         crypto_alg_lookup
> >depmod: *** Unresolved symbols in
> >/lib/modules/2.4.29custom1/kernel/crypto/proc.o
> >depmod:         crypto_alg_sem
> >depmod:         crypto_alg_list
> >depmod: *** Unresolved symbols in
> >/lib/modules/misc/windrvr6.o
> >depmod:         usb_ifnum_to_if_Rsmp_7f504340
> >depmod:         usb_alloc_urb_Rsmp_37eb1efb
> >depmod:         usb_register_Rsmp_6ab484a9
> >depmod:         usb_set_interface_Rsmp_fc4b0efa
> >depmod:         usb_clear_halt_Rsmp_3b248300
> >depmod:         usb_deregister_Rsmp_a38a432d
> >depmod:         usb_submit_urb_Rsmp_87e0f069
> >depmod:         usb_free_urb_Rsmp_986294e5
> >depmod:         usb_unlink_urb_Rsmp_1a73da9d
> >make: *** [_modinst_post] Error 1
> >
> >
> >It seems that modules_install runs depmod but fails
> >for some reason. The modules dependency is not the
> >issue as the compilation has been successful with
> same
> >default redhat kernel config file (being copied as
> >.config) on other 2 machines.
> >Why is depmod looking in /opt? My modules.conf file
> >does not have any path directive.
> >I have googled but only found a few open ended
> >questions. Any pointers please?
> >
> >Thanks and Regards;
> >Rituraj
> Somethings fubar someplace.  Start it over again
> from scratch.
> I also maintain continuity of .config's by copying,
> but you _must_, 
> after the copying, do a 'make oldconfig' and answer
> its questions.  
> I've never had a problem like that unless a patch
> was bad & it 
> scrolled offscreen un-noticed.  I've also had to
> download the kernel 
> archive again a couple of times, but only if getting
> the .bz2 
> versions, the .gz have always worked from the gitgo.
>  Its also bad 
> form to copy those .config's to a different machine,
> always get it 
> from the machine you are going to build it on in
> order to maintain 
> the continuity _for that hardware_.
> I do this often enough I've long since relegated the
> drudgery of a 
> kernel build to a couple of scripts that I have to
> edit the variables 
> of each time I run them, but they then take care of
> the building and 
> configuring of a new kernels src tree on my hard
> drive, then after 
> I've fixed the second script to $VER match the
> makefile, it gets run 
> to build and install the kernel, leaving me with the
> 30 second job of 
> editing /boot/grub/grub.conf.  I can, literally,
> download a new 
> patchset, tweek those two scripts, run them, and be
> rebooted into a 
> new kernel in about 25 minutes elapsed time if an
> fsck doesn't catch 
> me up, 8 to 10 of which is the runtime of the second
> script.
> Everyone who does this "keeping up with the Jones's"
> should over time, 
> develop their own personal bag of tricks such as
> those 2 scripts.
> A perusal of the bash man pages can be very
> educational, bash itself 
> is a pretty powerfull language.
> -- 
> Cheers, Gene
> "There are four boxes to be used in defense of
> liberty:
>  soap, ballot, jury, and ammo. Please use in that
> order."
> -Ed Howdershelt (Author)
> 99.34% setiathome rank, not too shabby for a WV
> hillbilly
> Yahoo.com and AOL/TW attorneys please note,
> additions to the above
> message by Gene Heskett are:
> Copyright 2005 by Maurice Eugene Heskett, all rights
> reserved.

Do you Yahoo!? 
Yahoo! Personals - Better first dates. More second dates. 

Reply to: