[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Driver for Radeon x300 series, ATI technologies

Robinson, Peter wrote:

Dear Debianers,

I am in the process of installing a Debain Sarge system onto a new Dell computer (dimension 8400). I have managed to get a base system installed with a 2.6.9 kernel, but I am having difficulties getting X to start. I have tried two different drivers (and needless to say, I have not found the answer in Google)

1) At the moment, I have indicated the "vesa" driver in the "Device" section of XF86Config-4. When I enter startx (or gdm), I get the message

X:warning; process set to priority -1 instead of requesting prioirtiy 0
_XSERVTransSocketOpen: socket() failed for local

Fatal server error: Cannot establish any listening sockets - Make sure an X server^isnt already running  (this is not the case according to ps aux)

xinit: Address family not supported by protocol (errno 97): unable to connect to X server.

2) I also tried to use the new driver provided by ATI
But this driver is provided only as rpm. So, I did "alien fglrx-4.3.0-3.14.6.i386.rpm"
When I then tried to do
dpkg -i  xxx.deb
I got the message (translated from German)
"Error in processing of fglrx_4.3.0-4.14_i386.deb (--install): attempt to overwrite /usr/X11R6/lib/libGL.so.1.2, which is in the package xlibmesa-gl"
FYI: the fglrx drivers are also available as Debian packages at:

deb http://www.stanchina.net/~flavio/debian/ ./

Does anyone have any ideas as to how to get this graphic card to work and which driver would be best suited?

Reply to: