[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sata drives

p_s wrote:
Clive Menzies wrote:

On (30/01/05 08:31), p_s wrote:

Clive Menzies wrote:

On (29/01/05 23:23), duke_p@saunalahti.fi wrote:

I am trying t o install debian testing to my new laptop, which has sata haddrives, and I miserably fail when partitioning.. Installer notifies that 'no partionable media found'

I tried to boot with:

Try expert26  IIRC .... It worked for me ;)


Didn't get far, the list of modules the installer offers here too is all for IDE chipsets.

I googled around and some suggest that turn off the sata from bios, but sadly that's not possible on my bios.

You are using the sarge d-i rc2 installer?

From memor: I setup a couple of servers with software RAID on SATA

drives in Decmber.  I booted into the installer with "expert26" and that
gave all sorts of options of packages to run during the install and
support for SATA and RAID were in there.

Yep, I have tried both, sarge netinstall (rc2) and the full images, both ended up similarily, no paartionable media.

I just tried it again with expert26, it suggests a heap load of modules it assumes necessary...(sorry the possible typos, couldn't copy/paste these..)

yenta_sockets, usb-storage. floppy, via82cxxx, trm290, triflex, slc90e66, sis5513, siimage, serverworks, sc1200, rz1000, piix, pdc202xx_old, opti621, ns87415, hpt34xx, generic, cy83c693, cs5530, cs5520, cmd64x, atiixp, and74xx, alim15x3, alim15x3, aec62xx, pdc202xx_new, ide-generic, ide-disk, ide-cd, isofs)

I allowed all, didn't know what parameters to pass to them though.

under Knoppix lspci output is revealed that the SATA Controller is:

0000:00:1f.2 IDE interface: Intel Corp. 82801FBM (ICH6M) SATA Controller (rev 04)

Any modules to load via the shell with modprobe possibly ?

Tried it once more... when proceeding to 'detect hardware' installer notified that module 'floppy' vas detected to be necessary abd after that it listed modules that are unavailable, but needed:



Reply to: