[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Retrieving photos via gphoto2

david wrote:

Dear all,

I have recently replaced my old Mandrake 9.0 installation with Debian Sarge, and in general I am extremely pleased.  However, I am having trouble getting gphoto2 talking to my Canon A80 (it is listed as a supported camera, and it worked fine before).  I have tried e-mailing the gphoto list, but no response.  I haven't seen anything yet on the lists or searching the internet.  I sinerely hope that someone on the Debian list can be of assistance.

I am calling gphoto2 from the console, logged on as root (so it should not be a permissions problem) - I have yet to get round to the business of creating a camera group, etc.  It has worked on just two occasions, and I don't know how I did this, it almost always returns an error.  Please see my e-mail to the gphoto list below for further details.  Moreover, I list the output from lsmod below, just in case that provides any clues - before and after a hotplug reset (they appear different for some reason).

Thank you!

Best wishes,

David Joyce

The first error is "canon_usb_lock_keys: Unexpected return of 0 bytes (expected 820) from "get picture abilities." ", but then another re-try produces the following error: "Could not apply USB settings". It then requires a reset of hotplug to get it back to square one (via "/etc/init.d/hotplug restart").


had some trouble on an older sarge with gphoto2 recognizing my canon eos 300D.

solved that by installing usbmgr as repacement for hotplug. and usbview just to see what i was doing.
the result:  gphoto2 worked fine afterwards.

(nowadays as you undoubtedly know the developers added a camera-group so that any user can download pictures from the camera)

maybe this can be of some help.

kind regards,


Reply to: