[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Getting "shutdown" to shut the power off.

On Sun, Jan 23, 2005 at 08:30:26PM +0000, Adam Funk wrote:
> Hardware: ASRock K7S8X motherboard, Athlon 1100 processor.
> Kernels: all the ones I've tried on this machine.
> Problem: shutting down ends with the message "Power down" but I have to
> cut the power off manually.
> I've tried booting with "apc=on" and "apm=power-off" kernel options, but
> they didn't help.  I find this message recurring in /var/log/messages:
> Jan 23 18:24:04 garcia kernel: apm: BIOS not found.
> I'd appreciate any suggestions.
> -- 
> Thanks,
> Adam
> -- 
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Hi Adam,

I had the same problem, but only when running a Multi-Processor kernel for 
some reason, i.e 2.6.7-1-686 works fine, but 2.6.7-1-686-smp doesn't shut 
off the power. In what I guess is just another way of doing what Andrew 
proposed, I just put an 'append' option into the bootmanager config file 
(lilo in my case):

append="<your other options here> apm=power-off"

Then I load the apm module without options and I get a full shutdown.

Good luck,


Reply to: