[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: routing table problem after power failure (sarge)

Jan, again thanx for your quick response!

The router is a simple zyxel modem in routing mode: Zyxel Prestige 650R31. Ping from outside is allowed (responsed by router), I forwarded all port 1-1023 requests to my debian server box. If nescesary, iptables will block them their. I've got three windows clients, a freesco printserver and one debian box, all connected to one sweex 8port 100Mbit cheap switch. The router=modem is connected to that switch too. The windows clients have no problems at all, Debian box was working well before this problem. I could browse www pages and do ftp on my server from inside and outside my lan.

I haven't created any strange firewall rules in my router, it has no firewall at all! Note: I configged my router this way, that when you enter mydomain.com from inside the lan (whatever the service ), it won't try to browse your localhost, but he will act the same way if it was from outside the lan, that means forwarding to debian box.

this is my /etc/hosts:       localhost        altijd        altijd      router

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

(i don't use ipv6 i believe)

"altijd" (EN: "always") is the name of my debian box

this is /etc/host.conf:
order hosts,bind
multi on

The box has only got two NIC's (different brandings) because I planned to use them as one 20/200Mbit NIC for faster Samba Access with two windows clients. Has not been implemented yet, when i look at the lights in the NIC's always one card is used. Both are up, when I ping the other, it blinks and responses.

I could reset my router and config it again, but that is a bit of a nasty job. The router has no problems after uptimes of 100 days, it seems to be reliable. Have you got any other ideas with this info?

Maybe I could redo the networking config part of my box,from the setup? (Stupid idea :-( )

I wrote this piece of text above just for history, because now it seems the

After pulling out one NIC cable from my debian box, I could ping and dig outside my lan. I did the same with the other cable too. Now I can ping, and my box is http:// accessible! But samba is not working, /etc/init.d/samba restart didn't help. I rebooted "altijd". Now the problem's are back, internet not accessible.

Samba still not working. I'll report after Win2k reboot, tomorrow. Restarting switch did not help.

Hope you're happy the problem was this stupid....

I'll continue tomorrow.


> Tnx to response Jan. This is what i did:
> restarted my router
> checked /etc/resolv.conf is ok:
> content: search .
> nameserver
> nameserver
Ok, that ought to work...

> tried to "dig"
> response:
> ; <<>> DiG 9.2.4 <<>>
> ;; global options:  printcmd
> ;; connection timed out; no servers could be reached
> tried to ping localhost, times out
> tried to ping router and lan, OK
You edited /etc/hosts.conf and added a localhost entry, didn't you?

> tried to ping dns servers, times out
Does your router happen to disallow ping packets? (I've seen the craziest

> turned off iptables, did this all again. Same results.
> Uninstalled bind9. No dependancies on it. Same results.
As long as wasn't listed as nameserver in /etc/resolv.conf,
bind9 should not have been in the way.

> run tracert google.com in windows (Debian box is other box than windows
> box, same internet connection). tried to ping them on linux in the same
> order. The first and next ip adresses after my (router) are not
> pingeable. That root server not, too.
Hmm. that's really strange. Wait, let me get your setup straight...
like that?

|  Windows   |-----\
+------------+     |         +------------+   /-----\
                   +---------|   ROUTER   |---|modem|--{{{ internet }}}
+------------+     |         +------------+   \-----/
|   Debian   |-----/          (

> Router is not running DCHP, all ip's in lan are static.
> I thought route -n was wrong, because the lo interface is not mentioned in
lo doesn't get a route on its own - it doesn't appear in my routing table, too.
Ah, just remembered something: If localhost is listed in your /etc/hosts
as I suggested, what does the "order" directive in /etc/host.conf say?
Should read "order hosts,bind"...

> Do i need to reload the /etc/hosts someway? Still I can't ping to
> localhost, but ping resolves is ip Idem in case of
> Pinging to their ip's stays ok.
No, that config file (resolv.conf and host.conf also) is reread

The only thing I can imagine is some weird misconfiguration of the router,
allowing connections from the Windows box, but not from the Debian. But
as you only reconfigured the Debian box and it worked before you began,
that's nearly impossible.

Hmm, I'm pretty much groping in the dark... Is that router a full-
featured Linux box that you could inspect (tcpdump'ing the incoming
packets from the Debian box, and tracing where they go to)?
Or have you tried temporarily dropping one of the interfaces, so that there's
only one possible route (and source IP) left?


Jan C. Nordholz
<jckn At gmx net>
<< signature.asc >>

MSN Zoeken, voor duidelijke zoekresultaten! http://search.msn.nl

Reply to: