[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: routing table problem after power failure (sarge)

On Mon, Jan 24, 2005 at 10:00:26PM +0000, Corné Jannemans wrote:
> Tnx to response Jan. This is what i did:
> restarted my router
> checked /etc/resolv.conf is ok:
> content: search .
> nameserver
> nameserver
Ok, that ought to work...

> tried to "dig"
> response:
> ; <<>> DiG 9.2.4 <<>>
> ;; global options:  printcmd
> ;; connection timed out; no servers could be reached
> tried to ping localhost, times out
> tried to ping router and lan, OK
You edited /etc/hosts.conf and added a localhost entry, didn't you?

> tried to ping dns servers, times out
Does your router happen to disallow ping packets? (I've seen the craziest

> turned off iptables, did this all again. Same results.
> Uninstalled bind9. No dependancies on it. Same results.
As long as wasn't listed as nameserver in /etc/resolv.conf,
bind9 should not have been in the way.

> run tracert google.com in windows (Debian box is other box than windows 
> box, same internet connection). tried to ping them on linux in the same 
> order. The first and next ip adresses after my (router) are not 
> pingeable. That root server not, too.
Hmm. that's really strange. Wait, let me get your setup straight...
like that?

|  Windows   |-----\
+------------+     |         +------------+   /-----\
                   +---------|   ROUTER   |---|modem|--{{{ internet }}}
+------------+     |         +------------+   \-----/
|   Debian   |-----/          (

> Router is not running DCHP, all ip's in lan are static.
> I thought route -n was wrong, because the lo interface is not mentioned in 
lo doesn't get a route on its own - it doesn't appear in my routing table, too.
Ah, just remembered something: If localhost is listed in your /etc/hosts
as I suggested, what does the "order" directive in /etc/host.conf say?
Should read "order hosts,bind"...

> Do i need to reload the /etc/hosts someway? Still I can't ping to 
> localhost, but ping resolves is ip Idem in case of 
> Pinging to their ip's stays ok.
No, that config file (resolv.conf and host.conf also) is reread

The only thing I can imagine is some weird misconfiguration of the router,
allowing connections from the Windows box, but not from the Debian. But
as you only reconfigured the Debian box and it worked before you began,
that's nearly impossible.

Hmm, I'm pretty much groping in the dark... Is that router a full-
featured Linux box that you could inspect (tcpdump'ing the incoming
packets from the Debian box, and tracing where they go to)?
Or have you tried temporarily dropping one of the interfaces, so that there's
only one possible route (and source IP) left?


Jan C. Nordholz
<jckn At gmx net>

Attachment: signature.asc
Description: Digital signature

Reply to: