[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4.26->2.4.29 breaks pcmcia [SOLVED]

On Mon, Jan 24, 2005 at 05:57:17AM -0500, Roberto Sanchez wrote:
> David Purton wrote:
> >Hi,
> >
> >I just upgraded to 2.4.29 on a laptop and now the system freezes when I
> >insert or boot with my xircom pcmcia network card.
> >
> >It just says:
> >
> >cs:memory probe 0x0c0000-0x0fffff: excluding 0x0c0000-0xcbfff
> >
> >And freezes, I have to turn the laptop off at the power button.
> >
> >I didn't change any pcmcia related options in my vanilla kernel.org
> >config.
> Do you have pcmcia compiled as modules or statically?  A while back I
> had a problem with going from 2.6.0-test4 to 2.6.0-test9 causing
> identical to what you are describing.  The solution was to compile it
> statically.  I even emailed the LKML a few times to try to get someone
> to help me track down the problem, but there was no interest.
> Your problem may a be a result of something that was backported from 2.6
> into 2.4 that is now causing the same issue there.

I do have them compiled as modules, but I've managed to fix things

I noticed from /var/log/messages, that with the older kernel, it was
initially probing a different memory range, so I just commented out all
lines except the one that worked in 2.4.26 in /etc/pcmcia/config.opts,
and it works again.



David Purton
For the eyes of the LORD range throughout the earth to
strengthen those whose hearts are fully committed to him.
                                 2 Chronicles 16:9a

Attachment: signature.asc
Description: Digital signature

Reply to: