[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mknod, /dev/hdb, /dev/cdrom problem

Andrea Vettorello wrote:

On Tue, 04 Jan 2005 02:45:23 +0200, Necati DEMiR <ndemir@demir.web.tr> wrote:
Andrea Vettorello wrote:

On Mon, 03 Jan 2005 21:38:34 +0200, Necati DEMiR <ndemir@demir.web.tr> wrote:


it is a cd-writer. i think debian knows a cd-writer is connected and
loads the module ide-scsi, but it doesn't create hdb,cdrom or sr* under
/dev/ directory.

it is not problem for me to use my cd-writer as a cd-rom. i wanna use it
as a cdrom. After solving this problem, i will try to use it as a
cd-writer, but my first aim is, to mount my cd-rom. OK? :)

First of all don't use SCSI emulation for your CD-ROM, then check if
in your /etc/udev/rules.d there's a symlink to ../cd-aliases.rules, if
not present create it, then restart udev...

i did the followings;

# ls -al /etc/udev/rules.d/
total 8
drwxr-xr-x  2 root root 4096 Dec 26 18:37 .
drwxr-xr-x  5 root root 4096 Jan  3 19:46 ..
lrwxrwxrwx  1 root root   19 Dec 26 18:37 cd-aliases.rules ->
lrwxrwxrwx  1 root root   13 Dec 26 18:37 udev.rules -> ../udev.rules
lrwxrwxrwx  1 root root   12 Dec 26 18:27 z_hal-plugdev.rules ->

# cd /etc/init.d

# ./udev restart
Recreating device nodes...done.

# ls /dev/
MAKEDEV  hda7       ram0    shm      tty19  tty35  tty51  ttyS1


ttyS41  urandom

as you see there is no hdb or cdrom still!

Have you checked if you have at least "ide-cd" module loaded? Modprobe it if not. And put a line in your /etc/modules too if not
present. The "ide-cd" depends on "ide-core" and "cdrom", so modprobing
it should load them too...


thanks to everybody! i solved my problem.
i forgot that everything needs module.
these are the steps how i solved my problem;

#modprobe ide_cd
#echo "ide_cd">>/etc/modules

again and again thanx to everybody!

Necati DEMiR
My Public Key => http://demir.web.tr/ndemir.asc

Reply to: