[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mknod, /dev/hdb, /dev/cdrom problem

On Mon, 03 Jan 2005 12:17:10 +0200, Necati DEMiR <ndemir@demir.web.tr> wrote:
> >Try giving the file system type in your mount command:
> >mount -t iso9660 /dev/hdb /mnt/cdrom
> >
> >
> it didin't work.
> i am telling from stracth;
> i rebooted the machine;
> then
> # dmesg|grep hdb
> ide_setup: hdb=ide-scsi
>     ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:DMA
> hdb: HL-DT-ST GCE-8400B, ATAPI CD/DVD-ROM drive
> # ls /dev/
> MAKEDEV    initctl  ram14    tty10  tty3   tty49  ttyS1   ttyS29  ttyS48
> adsp       input    ram15    tty11  tty30  tty5   ttyS10  ttyS3   ttyS49
> agpgart    kmem     ram2     tty12  tty31  tty50  ttyS11  ttyS30  ttyS5
> audio      kmsg     ram3     tty13  tty32  tty51  ttyS12  ttyS31  ttyS50
> console    loop     ram4     tty14  tty33  tty52  ttyS13  ttyS32  ttyS51
> core       mem      ram5     tty15  tty34  tty53  ttyS14  ttyS33  ttyS52
> dsp        mixer    ram6     tty16  tty35  tty54  ttyS15  ttyS34  ttyS53
> fb0        net      ram7     tty17  tty36  tty55  ttyS16  ttyS35  ttyS6
> fd         null     ram8     tty18  tty37  tty56  ttyS17  ttyS36  ttyS7
> fd0        port     ram9     tty19  tty38  tty57  ttyS18  ttyS37  ttyS8
> full       ppp      random   tty2   tty39  tty58  ttyS19  ttyS38  ttyS9
> hda        printer  rtc      tty20  tty4   tty59  ttyS2   ttyS39  urandom
> hda1       psaux    shm      tty21  tty40  tty6   ttyS20  ttyS4   vbi0
> hda2       ptmx     snd      tty22  tty41  tty60  ttyS21  ttyS40  vcs
> hda3       pts      sndstat  tty23  tty42  tty61  ttyS22  ttyS41  vcs1
> hda4       ram0     stderr   tty24  tty43  tty62  ttyS23  ttyS42  vcs7
> hda5       ram1     stdin    tty25  tty44  tty63  ttyS24  ttyS43  vcsa
> hda6       ram10    stdout   tty26  tty45  tty7   ttyS25  ttyS44  vcsa1
> hda7       ram11    tty      tty27  tty46  tty8   ttyS26  ttyS45  vcsa7
> hda8       ram12    tty0     tty28  tty47  tty9   ttyS27  ttyS46  video0
> hw_random  ram13    tty1     tty29  tty48  ttyS0  ttyS28  ttyS47  zero
> as you see there is no cdrom or hdb in /dev directory.
> what should i do after that?

This seems strangely empty. Are you using devfs or something similar?
udev maybe?


Reply to: