[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Please--sound


(please don't top-post)

Ted Parks (<th.parks@gmail.com>) wrote:
> On Sat, 18 Dec 2004 23:53:36 +0100, Andreas Janssen
> <janssen-andreas@t-online.de> wrote:
>> Am Samstag, 18. Dezember 2004 23:07 schrieb Ted Parks:
>>> [...]
>>> Now I have what I think is a permissions issue to resolve. Gnome-CD
>>> and Kscd will not play an audio CD unless launched from root.
>> Add yourself to the cdrom group:
>> adduser ted cdrom
>> Next, make sure that the device file for the drive belongs to the
>> cdrom group, not the disk group. (/Don't/ add yourself to the disk
>> group) If you use ide-scsi emulation (you mount the drive using
>> /dev/sg* or /dev/scd*), change group ownership for the sg files:
>> chgrp cdrom /dev/sg*
>> If you use the normal ide-cd driver and mount the drive using
>> /dev/hd*, change the ownership of the hd file, e.g.:
>> chgrp cdrom /dev/hdc
>> Make sure to get the correct device file. Don't change ownership of
>> the device file of your hard disk!
> I am still struggling with the audio CD issue. Just before I received
> your last message, I tried playing an audio CD with both GnomeCD and
> KsCD, launching these  both as user and root. I could get neither of
> the applications to play an audio CD. I don't think this is a driver
> issue, but, as you suggested, one of ownership or permissions.

Make sure that the drive is connected to the sound card, or use some
player that supports digital audio extraction, like xmms (options for
the cd player input plugin).

> When I tried to add myself to the cdrom group, I got the message that
> "tparks," my username, was already a member. I then executed the
> second command you suggested. I received no error messages, but I
> still can't play the audio CD.

What exactly was the command you ran? It should be

chgrp cdrom /dev/hdd

> I am pasting my /etc/fstab file. I thought it a bit strange that Sarge
> designated the cdrom drive as /media/cdrom0 instead of /mnt/cdrom, as
> Red Hat and Slackware do.

This is recommended according to new versions of the Linux File System
Hierarchy Standard (http://www.pathname.com/fhs/).

> Also, I am accustomed to the device name's listing as /dev/cdrom.

/dev/cdrom is only a symbolic link that should point to the real device
file (/dev/hdd in your case). You can't change ownership on the
symlink, change it on /dev/hdd instead.

> [...]
> /dev/hdd        /media/cdrom0   iso9660 ro,user,noauto  0       0

best regards
 Andreas Janssen

Andreas Janssen <andreas.janssen@bigfoot.com>
PGP-Key-ID: 0xDC801674 ICQ #17079270
Registered Linux User #267976

Reply to: