[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot connect to network now...

"Maurits van Rees" <maurits@vanrees.org> wrote in message
> On Mon, Nov 22, 2004 at 07:13:59PM -0000, Brian Coiley wrote:
> > "Brian Coiley" <bcap@clara.co.uk> wrote in message
> > news:33rql-1rI-19@gated-at.bofh.it...
> > > 9.    After much fiddling around with configuration, managed to get
> > > to do something using VESA, but just shows a grey screen with a black
> > cross
> > > in the middle, and entire system is locked up.
> Is it really locked up? Try CTRL-ALT-F1 to go to the first text
> console. (CTRL-ALT-F7 to go back usually.) Or right click with your
> mouse to see if a context menu comes up. I may be wildly off with my
> guess here, but it reminds me of a simple window manager. If that's
> the case you may want to install kde or gnome to get some more
> extensive graphics.
> I got a rather empty screen like yours once when I somehow failed to
> notice that I had uninstalled kde... ;-)

You may be correct: I've done "apt-get install gnome" now, and startX gets
me into something a bit more sensible looking.  Unfortunately, my USB mouse
doesn't work, and I get an error which reads "Error activating XKB
configuration.  Probably internal X server problem."  I then need to do
ctrl-alt-backspace to get out, 'cos I can't get far without the mouse.

Any suggestions anyone?

> > OK, here's some more info: considerable rummaging around revealed the
> > command "dhclient".  Executing this resulted in the somewhat
> > message "Unrecognized Kernel Version" or something like that.  More
> > rummaging around revealed that dhclient is in fact a script, wrapping
> > and 2.2 versions of the dhclient thingy.  No sign of a 2.6 version!
> > I ran the 2.2 version and guess what?  I immediately got a DHCP lease
> > started nattering to the network!
> 2.0 and 2.2 should be the version numbers of dhclient and have nothing
> to do with a kernel version. The error message seems strange. Googling
> may possibly give some hints. BTW, on the Debian servers I only see
> version 2.0. What does the following command show?
> dpkg-query -l dhc* | grep ii
> In my case:
> ii  dhcp-client        2.0pl5-19.1        DHCP Client

It shows the following:
ii  dhcp-client        2.0p15-11woody    DHCP Client

> > So what's gone wrong?  Presumably the 2.6 kernel broke something re
> > but what, and how do I fix it (other than by doing the above whenever I
> > boot)?
> I also don't always get a dhcp lease when I boot up. I just have one
> computer connected to a DSL router. The router needs some time to
> start up. The computer is faster and starts to request a dhcp lease
> before the router is fully up and running, so it doesn't work. When
> that's the case I have to run the dhclient command manually as
> well. Could this be your problem?

No, I don't think that's it.  The router is always on, and has had three
Windoze clients connecting with no problem for many, many months.  Also, the
Debian client was working with no problem until the upgrade to Sarge,
whereupon it wouldn't work at all, no matter how many reboots I tried.

> -- 
> Maurits van Rees | http://maurits.vanrees.org/ [Dutch/Nederlands]
> "Let your advance worrying become advance thinking and planning."
>  - Winston Churchill
> -- 
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact

Reply to: