[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Newbie Nvidia/Woody problem

Hi there,

Complete Linux newbie here.  Successfully partitioned the disk on my W2K
box, and got it dual-booting with Woody (installed from a CD set).  I
thought that was pretty cool, and I was going good!  Tried startx, and got
this: (EE) No devices detected.

Hmmm, no video driver presumably.  My video card is a an ASUS V9520 Magic
(Nvidia GeForce FX5200 Series).  No Linux drivers at Asus, so tried Nvidia:
lots there!  Unfortunately the most recent ones all refused to install
because they don't support kernel versions earlier than 2.4 (despite the
readme saying that 2.2.12 is the minimum).  The Woody install seems to have
given me 2.2.20.

So, by trial and error, I have finished up with driver version 5328.
However, when I run the Nvidia install, I finish up with the following
error: "Unable to load the kernel module nvidia.o.  This is most likely
because the kernel module was built using the wrong kernel header files.
Blah blah blah."

Now, I've used apt to install kernel-source-2.2.20.  I have used the
kernel-include-path switch on the Nvidia installer to point at the folder
containing the kernel.h file, which is what the installer seems to want.
Thus, my command line is this:

    sh NVIDIA-Linux-x86-1.0-5328-pkg1.run --kernel-include-path

But, I still get the error described above.

Incidentally, before the install fails,  I get a warning that "The compiler
used to compile the kernel was gcc 2.7; the current compiler is gcc 2.95."
Thus far I have overriden this warning and gone ahead anyway, but could
someone tell me how to set the CC environment variable, as suggested by the
installer, to get the correct compiler?

If all this is complete codswallop (or if indeed I am in the wrong
newsgroup!) please don't spare my feelings!  As I said, I am a complete
newbie, and all help will be very gratefully received, even if only to
direct me elsewhere!  If any technical help is forthcoming, please, please
treat me like an idiot!  I need actual commands to type!

Many, many thanks!


Reply to: