[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't use kb3 to copy cd's.

Justin Guerin wrote:

On Friday 05 November 2004 15:21, Damon wrote:
Justin Guerin wrote:
On Thursday 04 November 2004 16:09, Damon Chesser wrote:
I have two devices: hdc > cd writer, hdd > cd reader.  I can play audio
cd's from hdd, I can mount cd's with mp3's and play them.  I can burn
ISO's on hdc or make data cd's with hdc using k3b.  I never or almost
never copy a cd.  When I tried copying a cd from hdd to hdc via k3b,
k3b reports the cd is empty medium.  Different cd's, different types
of data.  Correct devices set up in k3b, using generic-mmc for cdrdao
driver for the burner and the reader.  Problem pursists as root or
user.  What am I missing?  I have R&R'd the reader with a different
reader, same problem.  If you need more info, please ask, I have tried
to provide as much as needed.

Damon L. Chesser
You might want to rearrange your hardware after reading about the -immed
option in the cdrecord man page:
-immed Tell cdrecord to set the SCSI IMMED flag  in  certain  commands
(load/eject/blank/close_track/close_session).   This  can  be  useful on
broken systems with ATAPI harddisk and CD/DVD writer on the same bus or
with SCSI systems that don't use disconnect/reconnect.  These systems
will freeze while blanking or  fixating  a  CD/DVD  or  while  a DVD
writer is filling up a session to the minimum amount (approx. 800 MB).
            Setting the -immed flag will request the command to return
immediately while the operation proceeds in the background, making the bus usable for the other devices and avoiding the system freeze.
This is an experimental feature which may work or not, depending on
the model of the CD/DVD writer.  A correct solution would be to set up
a correct cabling but there seem to be notebooks around that have been
set up the wrong way by the manufacturer.  As it is impossible to fix
this problem in notebooks, the  -immed  option has been added.
            A  second  experimental  feature  of the -immed flag is to
tell cdrecord to try to wait short times while writing to the media.
This is expected to free the IDE bus if the CD/DVD writer and the data source are connected to the same IDE cable. In this case, the CD/DVD
writer would otherwise usually block the IDE bus for nearly all the
time making it impossible to fetch data from the source drive. See also minbuf= and -v option.

            Use  both  features at your own risk.  If it turns out
that it would make sense to have a separate option for the wait
feature, write to the author and convince him.

Hope that helps,
Justin Guerin
It kinda helps :)  I am not (or am not supposed to be using) scisi
emulation.  I am using a image from debian, so maybe somehow
scsi is emulating, only the devices do show up as hdd and hdc, both on
the same controler.  How can I check for scsi emulation.  I don't think
I can turn it off in the kernel as I use a thumb drive which does show
up as a scsi device (sda1 FWIW).  I am leaning toward a kernel config
problem, but I don't know what it would be.

Did you try copying the CD with the -immed flag?  If so, what happened?

Did you try moving your CD writer (or reader) to the other IDE bus? If so, what happened?

SCSI emulation is not your problem. Your problem is having the reader and writer on the same IDE bus. However, to check for SCSI emulation, check your boot loader to see if you've appended the option hdx=ide-scsi. Given that you're accessing the drives as hdc and hdd, which are IDE device names.

Justin Guerin

p.s. please reply to the list, as I'm subscribed and more people can help than just me.
I thought I did respond to the list. Sorry. Will check the other stuff and report back.

Damon L. Chesser

Reply to: