[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: post-2.6 upgrade problems

Thanks, Nicos.

Unfortunately, the new initscripts wants libc6 >= 2.3.2.

I tried to manually mount devpts but the problem remained.

Will 2.6 and stable just not jive? I'm ok sticking with 2.4.27 if that's the case, I just need to get away from 2.4.19 because the xfs patch is no longer available thanks to SCO.

Nicos Gollan wrote:
On Wednesday November 3 2004 23:34, Aaron Thoreson wrote:

After an upgrade from 2.4.19 stable to 2.6.9 custom (maybe too
ambitious?) I've lost the ability to ssh into the upgraded box.

auth.log is reporting
error: openpty: No such file or directory
error: session_pty_req: session 0 alloc failed

The problem is that you don't have the PTS filesystem mounted. This should normally be done by the mountvirtfs init script (package initscripts). Stable doesn't have this script since it was pretty useless back when stable was born, so I guess you'll have to see how it works or try and install it along with its dependencies.

The relevant output of mount is:
devpts on /dev/pts type devpts (rw,gid=5,mode=620)

devfs should theoretically handle the rest (if you have devfsd running).

Aaron Thoreson
Network Group
Midcontinent Communications

Reply to: