[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel boot problem?

Stefan O'Rear wrote:

On Wed, Sep 01, 2004 at 01:43:47AM +0100, Grant wrote:
Paul Johnson wrote:
Grant <orblists@orbysrealm.com> writes:
I have compiled now 4 kernel's and the first two kernel's got stuck on
this message at boot.

VFS: Cannot open root device "hda1" or unknown-block(3,1)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)
Sounds like you're making a kernel with no initrd and all the
filesystems are modules.  initrd is a pain in the butt, just compile
the filesystems you need at boot time right into the kernel.
Forgot to say that i am using make-kpkg then i am transfering it to my laptop to then installing the kernel.

I just tried another 3times and this time i made sure i made the filesystems in the kernel and not modules, but i still got the same error.

Is there a way i can use make-kpkg to make a initrd as the 2.6.7 (original kernel) has one but the one i keep trying to make is missing, is that the problem ? how would i make one and transfer it to the laptop...

VFS: Cannot open root device "hda1" or unknown-block(3,1)

Try compiling your IDE controller and drive drivers into the kernel. (if
you're one of the 1e-something of us who uses SCSI, change the


*slaps forhead!*

I didnt think.... someone said about doing that for the filesystems, i never thought about it might need it for other things, i guess that initrd is quite important if you use modules for your kernel...

Anyways i will give that a try.

Thanks again

Reply to: