[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Getting photos from USB compactFlash into linux

I've always wanted automounter to work.  
I thought of it as mounting an NFS disk on another
computer, but it would be cool if it works for flash.
It's still not working, and I wonder if the compactflash 
reader hardware is
burned out or if the flash card is not formated:

root@a2000xp:/#  mount -t vfat /dev/sda1 /usb
mount: /dev/sda1 is not a valid block device
root@a2000xp:/# ls -lad /usb
drwxr-xr-x  2 root root 4096 Jul 28 19:47 /usb

Oh well, still not working.  I'll try some more things
in the morning. Thanks.

This file below (auto.misc)
looks like it needs a flash line like maybe:
#below added july 28,2004 
flash           -fstype=fvat,sync,nodev,nosuid          :/dev/sda

# $Id: auto.misc,v 1.2 1997/10/06 21:52:04 hpa Exp $
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage
kernel          -ro                                     ftp.kernel.org:/pub/linux
boot            -fstype=ext2                            :/dev/hda1
removable       -fstype=ext2,sync,nodev,nosuid          :/dev/hdd
cd              -fstype=iso9660,ro,sync,nodev,nosuid    :/dev/hdc
floppy          -fstype=auto,sync,nodev,nosuid          :/dev/fd0
#below added july 28,2004 
flash           -fstype=fvat,sync,nodev,nosuid          :/dev/sda

# Knoppix automounter file for Directory /mnt/auto
# umask=000 only works for msdos/vfat floppies, but otherwise the floppy is read-only.
floppy  -fstype=auto,user,exec,umask=000        :/dev/fd0
cdrom   -fstype=auto,user,exec,ro       :/dev/cdrom
#below added July 28,2004
flash   -fstype=vfat,user,exec,ro       :/dev/sda
# The following entries are auto-generated by knoppix-autoconfig

 --- On Wed 07/28, Micha Feigin < michf@post.tau.ac.il > wrote:
From: Micha Feigin [mailto: michf@post.tau.ac.il]
To: debian-user@lists.debian.org
Date: Thu, 29 Jul 2004 03:17:55 +0300
Subject: Re: Getting photos from USB compactFlash into linux

On Wed, Jul 28, 2004 at 04:42:38PM -0400, J F wrote:<br>> <br>> I would like to get Debian to recognize my pictures on<br>> from my camera which uses  compact flash.<br>> <br>> >From a posting by dances with crows:<br>> >USB Mass Storage devices are seen as SCSI disks.  Unless you have any<br>> >real SCSI disks or any other USB storage devices, your CF reader will be<br>> >seen as /dev/sda.  USB Mass Storage devices are almost always<br>> >partitioned so they've got 1 partition covering the entire medium.  If<br>> >everything else is working, you plug the USB CF reader in, then do<br>> >"mount /dev/sda1 /mnt/somewhere". <br>> <br>> So I typed:<br>> root@a2000xp:/etc/apt# mount -r -t vfat /dev/sda1 /mnt/auto/sda<br>> mount: mount point /mnt/auto/sda does not exist<br>> <br>> root@a2000xp:/etc/apt# mkdir /mnt/auto/sda1<br>> mkdir: cannot create directory `/mnt/auto/sda1': Permission denied<br>> <br>> root@a2000xp:/etc/apt# ls -lad /mnt/auto/<br>> drwxr-xr-x  2 root root 0 Jul 2
 8 11:56 /mnt/auto/<br>> <br>> root@a2000xp:/etc/apt# id<br>> uid=0(root) gid=0(root) groups=0(root)<br>> <br>> root@a2000xp:/etc/apt# mkdir /mnt/auto/sda1<br>> mkdir: cannot create directory `/mnt/auto/sda1': Permission denied<br>> <br>> root@a2000xp:/etc/apt# cd /mnt/auto/<br>> root@a2000xp:/mnt/auto# ls -lat<br>> total 4<br>> drwxr-xr-x  2 root root    0 Jul 28 11:56 .<br>> drwxr-xr-x  5 root root 4096 Feb 10 16:34 ..<br>> root@a2000xp:/mnt/auto# df -a .<br>> Filesystem           1K-blocks      Used Available Use% Mounted on<br>> automount(pid856)            0         0         0   -  /mnt/auto<br>> <br>> root@a2000xp:/mnt# mount<br>> /dev/hda1 on / type ext3 (rw,errors=remount-ro)<br>> none on /proc type proc (rw,nodiratime)<br>> devpts on /dev/pts type devpts (rw,gid=5,mode=620)<br>> tmpfs on /dev/shm type tmpfs (rw)<br>> sysfs on /sys type sysfs (rw)<br>> automount(pid856) on /mnt/auto type autofs (rw,fd=5,pgrp=856,minproto=2,maxproto=4)<br>> none on /proc/bus/usb type 
 usbfs (rw)<br>> <br>> Is /mnt/auto ( type autofs ) the correct place to<br>> mount the USB compactFlash?<br>> What is the last line item listed by mount:<br>> none on /proc/bus/usb type usbfs (rw) ??<br>> <br><br>you have autofs installed and running which automatically mounts file<br>systems on access and then unmounts them again after some time of no<br>usage.<br><br>If its configured properly you can probably do something like ls<br>/mnt/auto/sda or ls /mnt/auto/sda1 and the directory will be created<br>automatically and the usb flash device will be auto mounted.<br><br>What is the content of /etc/auto.* (there should be several<br>files). Otherwise you can create another directory under /mnt and try<br>mounting on that, such as mkdir /mnt/flashdisk, mount ...<br>You will also need the proper modules running, that would be the usb<br>modules, the usb-storage and the scsi modules, sd IIRC is the scsi disk<br>module.<br><br>If you have autofs running they should be loaded a
 utomatically (sd<br>sometimes forgets to though, on some systems).<br><br>> Thanks in advance,<br>> J<br>> <br>> <br>> _______________________________________________<br>> Join Excite! - http://www.excite.com<br>> The most personalized portal on the Web!<br>> <br>> <br>> -- <br>> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org <br>> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org<br>> <br>>  <br>>  +++++++++++++++++++++++++++++++++++++++++++<br>>  This Mail Was Scanned By Mail-seCure System<br>>  at the Tel-Aviv University CC.<br>> <br><br><br>-- <br>To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org <br>with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org<br><br>

Join Excite! - http://www.excite.com
The most personalized portal on the Web!

Reply to: