[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kernel upgrade: mkinitrd: module raid1 not found

On Monday 31 May 2004 12:00, Bob wrote:
> Hi,
> I'm attempting to upgrade from 2.6.2 to kernel 2.6.6, compiling from the
> kernel-source package,
> make-kpkg --initrd kernel_image modules_image
> and trying to install with dpkg -i
> This used to work fine, but now I get
> Setting up kernel-image-2.6.6-jn040531a (dizzy.1.0) ...
> /usr/sbin/mkinitrd: add_modules_dep_2_5: modprobe failed
> FATAL: Module raid1 not found.
> Failed to create initrd image.
> My system is indeed running raid1, but raid1 support is compiled into the
> kernel (both the current 2.6.2 and the new 2.6.6).
> I must admit that I don't understand the details of using or updating
> modules; in the past I just did the above steps and everything worked..
> This is an extract of 'grep -R raid1 /etc':
> /etc/modutils/raidtools2:alias md-personality-3 raid1
> /etc/modules.conf:alias md-personality-3 raid1
> /etc/modprobe.d/aliases:alias md-personality-3 raid1
> I tried to comment out these lines but I still get the error.
> Any help appreciated! I guess the raid1 module is not required since it
> is compiled into the kernel? If you have any hints, please let me know.
> Thanks a lot!
> Bob

Hi Bob,
	You are correct: a raid1 module is not required since you compiled it into 
the kernel.  Actually, because you compiled it into the kernel, no module 
was built, which is why it can't be found.  To fix this error the most 
simple way, re-configure your kernel to build raid1 as a module, then 
compile again.
	On the other hand, since you're building your own kernel, why not just 
build in all the components you know you'll need at boot time, and build 
the rest (ones that you only think you might need) as modules.  That way, 
you won't even have to use an initial ram disk.
	But back to fixing your error without rebuilding your kernel: where is 
mkinitrd's confdir?  It's supposed to be /etc/mkinitrd, and if it's trying 
to put the raid1 module into the initial ram disk, then it should be in the 
config files somewhere, but your grep doesn't seem to have found it.  It's 
possible it's in /usr or somewhere else.  If you find it, check to see that 
that's not the culprit.
	Let the list know what route you decide to take and how it works.
Justin Guerin

Reply to: