[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Wireless PCMCIA Card No Longer Works--Can't Identify Source of Problem

Adam Kessel wrote:
My SMC 2632W V3 PCMCIA 802.11b card recently stopped working under Debian

Other PCMCIA cards (e.g., modem) work on the same system, activating and
loading the proper modules, so PCMCIA isn't completely broken.

The same card works in another system (also running unstable) so the card
isn't broken.

What's most odd is 'cardctl ident' reports 'no product info available'
and 'cardctl config' reports 'not configured'.
Nothing appears in dmesg when the card is inserted or ejected.

The card doesn't light up or trigger the 'bell' sound when it is
The module for the card (atmel_cs) is properly defined in
/etc/pcmcia/smc.conf (that file hasn't changed since it stopped working)
and the the module is in the proper location.

I get the same result with 2.6.4 and 2.6.5, yet I'm almost certain the
card was previously working under both kernels.

Can anyone offer some ideas about how to go about diagnosing this?  I'm
at a loss because there are no useful log messages.  It's as if the card
just doesn't exist to the system.

Do you happen to remember what you did just before it stopped working? Or do you at least remember whether you had just upgraded or recompiled your kernel? This would most likely be the easiest route to identifying the problem.

If so, do you have a backup of a kernel config from when the card was working, to compare with your current kernel config?

Can you otherwise modprobe or insmod the atmel_cs module successfully?

It's not clear from your post which kernel you know (currently, and for certain) that the card is working on, and which kernel it is not working on? I read you to be saying that you have tried both a 2.6.4 kernel and a 2.6.5 kernel on this system, and the card fails to work under both.

This appears to be an external module; I don't recognize the smc.conf file. Are you certain that the version you are using is reported by the distributor to work with the kernel you are attempting to run it under?

From what you describe, and this seems to be your assessment as well, it is unlikely that this is a hardware problem. And there's never been any instance at all of a computer error occurring in a 9000 series.


Reply to: