[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: authenticate via NTLM & AD

You need to give clients access in the APS config! Maybe that helps?

> Hi,
> i'm getting closer but it's still not working.
> First, i've installed the Jana server but i couldn't
> even use it from my windows machine.
> I mean it worked but i wasn't able to establsh a connection
> through it.
> So i focused on APS again although the tests that i did before
> i initially mailed the list didn't work.
> Here are the steps that i did:
> 1. Install aps on windows, listen to port 3128.
> 2. Surf from the same machine using windows aps on port 3128.
>    Result: WORKS
> 3. Surf from the debian woody using windows aps on port 3128.
>    Result: FAILS
> 4. Install aps on the debian machine, listen to port 3128.
> 5. Surf from the windows machine using the debian machine aps proxy
>    Result: WORKS.
>    Now i'm sure the aps program works on Linux & Windows.
> 6. Surf from the debian woody using the debian machine aps proxy.
>    Result: FAILS
> Somewhere there is a problem with the Linux.
> This is what i've tried to get it to work:
> 1) Changing /etc/apt/apt-conf
> Setting Acquire::http::Proxy "http://winpcname.domain.be:3128";;
> or if running aps on linux
> Setting Acquire::http::Proxy "http://linuxpcname.domain.be:3128";;
> Pinging winpcname.domain.be and linuxpcname.domain.be works.
> apt-get fails again. It seems to get the correct ip for the names
> in the sources.list yet the connection times out.
> When the connection hangs and i run netstat -na i can see this:
> tcp 0 1     SYN_SENT
> is the ip of the linuxserver (and this is taken when
> i initiate an apt-get update from the linux server with aps also
> running on the server)
> When i look at the aps console there are no signs of any connection
> attempt so it seems as if the proxy settings are ignored for http
> attempts?
> 2) I tried setting http_proxy too but same result
> 3) Telnetting to winpcname.domain.be/linuxpcname.domain.be works.
> For instance: telnet linuxpcname.domain.be 3128
> Works or at least i can see on the console that APS registers a
> connection.
> 4) To test further i've installed apache and a simple site on the
> windows machine and tried to do a wget.
> It worked, wget connected fine and downloaded the index.html.
> I checked iptables -L but all default policies are set to ACCEPT.
> I have no clue anymore as to what happens.
> What i can think off:
> 1) Problem with the routing
> My routing table on the linux looks like this:
>   *    U  0 0 0 eth0
> default       UG 0 0 0 eth0
>    where is the default gateway of the network
> 2) apt-get doesn't take in account the http_proxy or proxy setting
> in /etc/apt/apt-conf. But this seems highly unlikely.
> Anybody know what might be causing this?
> Any other stuff i can check.
> Thanks,
> Benedict
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
> listmaster@lists.debian.org

Reply to: