[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: HELP! - My linux server won't boot anymore

>I had something similar once, (not really, since I screwed up my lilo
manually ;) ).
>Here's what I did, get Knoppix (knoppix.org) if you don't already have it.
>Boot from the knoppix disk, mount your root filesystem. Chroot into it.
Edit your lilo configuration. Get out of the chroot jail, 
>unmount the filesystem.
> Reboot and remove the knoppix disk.
> That's the short version, but you may want to look at this step-by-step
> http://www.troubleshooters.com/linux/knoppix/knoppix_rescue.htm
>It's a breeze, and very good for your confidence ;)

Things are not looking good.

I ran up KNOPPIX
I unlinked my vmlinuz and initrd.img files and re-linked then to the old
kernel 2.4.25-1-686

Still get the same problem

RAMDISK: Couldn't find valid RAM disk image starting at 0
kernel panic: VFS: Unable to mount root fs on unknown-block(3,2)

I just  don't understand what is going on. 2.4.25 was working perfectly
before. Everything turned to shit when I installed 2.6.5.


Reply to: