[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: HELP! - My linux server won't boot anymore

On Friday 07 May 2004 01:55, Daniel F Garcia shoved this in my mailbox:
> Things are not looking good.
> I ran up KNOPPIX
> I unlinked my vmlinuz and initrd.img files and re-linked then to the old
> kernel 2.4.25-1-686
> Rebooted
> Still get the same problem
> RAMDISK: Couldn't find valid RAM disk image starting at 0
> kernel panic: VFS: Unable to mount root fs on unknown-block(3,2)

You _did_ remember tot run lilo after you made those changes did you?
Just changing the configuration file doesn't do the trick. You need to run 
lilo to enforce the changes.
That's why you have to be in the chroot jail, to make sure your running the 
lilo on your disk, and not the lilo on your knoppix cd.

If you forgot to run lilo, just use knoppix again, check if all is ok in 
lilo.conf and punch in the 4 magic characters:


that should do it :)


This e-mail and any attached files are confidential and may be legally privileged. If you are not the addressee, any disclosure, reproduction, copying, distribution, or other dissemination or use of this communication is strictly prohibited. If you have received this transmission in error please notify A.S.T.R.I.D.  nv/sa immediately and then delete this e-mail.

Reply to: