[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

No sound when playing games



Hi!

I have tried several games, but never hear any sound. This makes it a
bit hard to play some games.

I use kernel 2.6.5 with soundcore built as a module. I have compiled and
installed ALSA version 1.0.4. Playing movies and music works perfectly
fine, but the games dont give any sound. It's probably some issue with
games using OSS, whilst I am using ALSA. However, I have OSS-emulation
installed, so I don't get it.

My sound card is Terratec Aureon 7.1 Space, and to use the ALSA-driver,
I usually have to specify the plughw-device; "mplayer -ao alsa9:plughw",
xmms: "plughw:0,0,0" etc.

"% lsmod" gives:
Module                  Size  Used by
snd_pcm_oss            52516  0
snd_mixer_oss          19712  2 snd_pcm_oss
snd_ice1724            38340  3
snd_ice17xx_ak4xxx      4352  1 snd_ice1724
snd_ac97_codec         63620  1 snd_ice1724
snd_pcm                95780  2 snd_pcm_oss,snd_ice1724
snd_page_alloc         11396  1 snd_pcm
snd_timer              25732  1 snd_pcm
snd_ak4xxx_adda         6144  2 snd_ice1724,snd_ice17xx_ak4xxx
snd_mpu401_uart         8064  1 snd_ice1724
snd_rawmidi            24864  1 snd_mpu401_uart
snd_seq_device          8456  1 snd_rawmidi
snd                    55268  14
snd_pcm_oss,snd_mixer_oss,snd_ice1724,snd_ac97_codec,snd_pcm,snd_timer,snd_ak4xxx_adda,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               9952  2 snd
nvidia               2075112  12

I have recently tried "Enemy Territory", it has a configfile with these
sound related parameters, but I don't know what they all mean:

seta com_soundMegs "24"
seta snddevice "/dev/dsp"
seta sndchannels "2"
seta sndspeed "0"
seta sndbits "16"
seta s_wavonly "0"
seta s_defaultsound "0"
seta s_mixPreStep "0.05"
seta s_mixahead "0.2"
seta s_khz "44"
seta s_doppler "1"
seta s_separation "0.5"
seta s_musicvolume "0.593750"
seta s_volume "0.8"

When I start "Enemy Territory" I get this message:

------- sound initialization -------
/dev/dsp: Input/output error
Could not mmap /dev/dsp
------------------------------------

What may be the cause of the silent games?

Regards,
Lars Tobias Borsting



Reply to: