[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

eth0 down (using Sarge)

I am running Sarge and kernel 2.4.24-1-k7.  Yesterday I rebooted the
system and was then unable to connect to my home network (two boxes) and
so I could not connect to the internet (the other box is my gateway).
Fortunately, I could boot using the my older kernel (2.4.18-bf2.4) and I
could connect just fine.  As of today, even that does not work.  I have
been forced to use the Red Hat that was originally on this machine in
order to get access to my network (but this verifies that the problem is
NOT hardware).

A little background:

Two days ago, just before the problem started, I did an apt-get upgrade.
 I did not see anything that looked like it would cause a problem,
especially since, at that time, it seemed like it was only a problem
under the 2.4.24-1-k7 kernel.

Yesterday, I tried to do another upgrade, hoping that whatever the
problem was had been noticed and a fix posted.  The only packages that
were DL'd for upgrade were ppp, ifupdown, and debootstrap.
Unfortunately, apt-get choked and suggested using apt-get -f install for
the following packages, and then listed NO packages.

This morning, I tried to do an apt-get -f install for all three of the
packages DL'd yesteday.  Apt get still chokes.  I did a fresh update and
then tried upgrade again, still no good.

I then tried to reboot using the 2.4.24-1-k7 kernel, just in case things
miraculously started to work (it happens sometimes).  Not only is it not
working, but fsck choked at boot and I got dropped into a root shell for
maintenance to run fsck manually.  I sat there for several minutes
holding down the 'y' key while hundreds (if not thousands) of messages
flashed by, requiring confirmation.  I then rebooted, but still no
network.  Then I rebooted, again, using the bf24 kernel and it can no
longer connect to the network.  That was when I resorted to using the
original Red Hat installation (I'm glad I didn't delete it, as I had
been thinking of doing.)

Is this a problem that others have been having, or have I somehow messed
things up all by myself?  I can still boot into the Debian system, I
just don't have any network.  Any suggestions as to which files I should
check to see if they got messed up?

All help appreciated.


Reply to: