[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[solved!] Sandisk Cruzer USB flash drive -- gaah!

On Mon, Mar 01, 2004 at 11:47:58AM -0500, Matt Price wrote:
> Hey everyone,
> I seem to havel ost my trusty old usb flash drive, so I shelled out
> $70 for a new one -- and carelessly bought a Sandisk Cruzer 256meg
> model.  Gaah!  I can't get it to work!!  

solved the probleem -- the device was defective!  returned it, bought
a new one, eveyrone's happy now.  no problems.

hopefully the next person withthis problem ill find this post via

> with the old drive, I simply plugged the thing in, usb-storage took
> over and the drive was assigned /dev/sda(something or other).  
> Now, dmesg gnerates this when the drive plugs in: 
> hub.c: new USB device 00:11.2-1.2, assigned address 19
> usb-uhci.c: interrupt, status 2, frame# 1292
> usb.c: USB device not accepting new address=19 (error=-110)
> hub.c: new USB device 00:11.2-1.2, assigned address 20
> usb.c: USB device not accepting new address=20 (error=-110)
> [root@anarres<503>/home/matt]$ 
> note that this is the output for a single plug-in event -- that is,
> the kernel tries to talk to it twice before giving up.  
> On the web I see postings indicating that people have gotten it
> working.  But I can't do it!  any suggestions?  
> btw, I'm running sid on an Athlon CPU with a self-rolled, make-kpkg
> 2.4.23 kernel; I think all the relevant modules are up and running,
> see the output of lsmod (attached below).
> I'm kinda desperate for help, and pretty well need this to work in the
> next couple of days -- so any assistance is desperately appreciated!
> thanks,
> matt

Reply to: