[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

What makes /dev/hdb1 say it's mounted/active when it isn't?

I hope this is the final stage in configuring this machine as a RAID1 
mirrored, three ethernet port firewall ... but I'm not quite there 

I've followed the guide at:

which had turned up on a debian list search to try to set up the 
RAID1 mirror of the boot/root drive.  I installed to /dev/hdb1 
(/dev/hda is the CDROM and perhaps I should have changed that first). 
Loaded 2.2.20, got 2.4.19 sources, compiled RAID1 support into the 
kernel (still can't get rid of one complaint about a missing 
character set module but don't think that's causing any real 
problems), made the identical /dev/hdc1 into a somewhat smaller linux 
autodetect RAID format partition, mounted it as 2nd drive in a RAID1 
drive using:
  mdadm --create /dev/md0 --level=1 --raid-disks=2 missing /dev/hdc1
which worked fine, mkfs -t ext3 /dev/hdc1, mount it to /mnt1, 
cp -ax / /mnt, tweak /etc/fstab ... /dev/md0 mounts fine, tweak lilo 
conf to boot from /dev/md0, reboot -- fine, finally come to add 
/dev/hdb1 into the array after resetting the partition type to 
autodetect RAID ... 

.. no go, system complains that /dev/hdb1 is mounted or that an inode 
is active:
md: can not impport hdb1, has active inodes!
md: error, md_import_device() returned -16

I assume that's because the boot is still from /dev/hdb but if so, 
how come the howto says this should work.  Seems that nothing I do 
can shift this and if I set the partition back to linux I find I 
can't mount the drive despite rebooting as I get:

mount: /dev/hdb1 already mounted or /mnt1 busy

/mnt1 isn't busy (I can create a completely new mount point: no 
difference) and mount shows that /dev/hdb1 isn't mounted.

I've tried all sorts of tweaking with lilo.conf to remove any calls 
to /dev/hdb but either these don't change anything, or else lilo 
complains that it can't install to the target (e.g. /dev/md0).

As usual, I've read through the docs and man pages and done some 
searching around but can't find any explanations.


PSYCTC: Psychotherapy, Psychology, Psychiatry, Counselling
   and Therapeutic Communities; practice, research, 
   teaching and consultancy.
Chris Evans & Jo-anne Carlyle
http://psyctc.org/ Email: chris@psyctc.org

Reply to: