[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel 2.6 and module-init-tools

On Fri, Jan 02, 2004 at 02:21:18AM +0530, Deboo said
> Debian Woody system, compiling 2.6 time and again keeps giving a "VFS:
> Kernel Panic: Unable to mount root fs" error, however many times I
> recompile. I do not have module init tools installed. 

Then you can't use modules AT ALL with your 2.6 kernel.

> Installing module-init-tools says that it  conflicts with modutils ...
> the doc for 2.6 says that they can co-exist. Now what's happenning
> here? 

The module-init-tools package you have is broken, or you didn't install
it properly.  Add this line to /etc/apt/sources.list

deb http://www.fs.tum.de/~bunk/debian woody/bunk-2 main contrib non-free 

then run "apt-get update" and "apt-get install module-init-tools".  Then
remove the line and "apt-get update" again.

> How do I compile and install kernel 2.6? 

If you've never compiled a kernel before, why do you want to start right

> Is there any good resources/articles about 2.6 ? 


Rob Weir <rweir@ertius.org> | mlspam@ertius.org  |  Do I look like I want a CC?
Words of the day:  counter terrorism Verisign offensive information warfare SSL

Attachment: signature.asc
Description: Digital signature

Reply to: