[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bootup Freezes

On Thu, Dec 11, 2003 at 10:09:11AM -0600, Kent West wrote:
> Thomas H. George wrote:
> >For the past few weeks my system frequently freezes or starts in (none) 
> >tty1 on bootup.   The freezes come at different points in the bootup 
> >sequence.  When this happens I can recover by booting up with bbc-2.1 
> >from a cd, running e2fsck -f on each partition (occasionally inodes are 
> >incorrect, often no problems are found) and then rebooting from the hard 
> >drive.  When the system is rebooted in this way there are no problems in 
> >running any of the programs I use.  I have been unable to pinpoint the 
> >source of this bootup problem.
> >
> >The system is testing and the kernel is 2.4.22 compiled with the 
> >/mm/mmap.c patch.  I regularly run apt-get dist-upgrade.
> >
> >memtest is installed, finds no problems with memory.
> >smartmontools is installed, the long test finds no problems with the 
> >hard drive.
> >clamscan run recursively from / finds no viruses
> >chkrootkit finds nothing
> >
> >I believe the problem started when I compiled kernel-source-0.6.0-test9 
> >and used this kernel to take advantage of the usb 2 speed of a usb dvd 
> >burner.  This worked fine but with no wireless lan access.  In an 
> >attempt to solve this I downloaded and compiled 
> >linux-wlan-ng-0.2.1-pre10 but still had no wireless access.
> >
> >The one consistant symptom  is the message
> >
> >   p80211knetdev_hard_start-xinit: Tx attempt prior to association, 
> >frame dropped
> >
> >which is repeated many times during the shutdown proceedure frequently 
> >interrupting the normal sequence of shutdown messages.  Apparently some 
> >record is stored that affects the next bootup attempt.
> >
> >I have attempted to correct this by recompiling the 2.4.22 kernel after 
> >first running mrproper and by then using apt-get install to get the 
> >debian version of linux-wlan-ng-0.2.0 and reconfiguring  and installing 
> >this program again after first running make mrproper.   This has not 
> >solved the problem.
> >
> >I would greatly appreciate any insights as to what to try next or any 
> >observations about things I have done wrong or failed to do.
> >
> >Tom George
> >
> >
> You might try booting a few times from a Knoppix CD, just to eliminate 
> hardware problems.
> I started having similar problems a few weeks ago. I finally tried 
> Knoppix, and found it froze the box also, and after some more diagnosis 
> (including swapping out the processor) came to the conclusion that my 
> mobo had turned south on me. But for quite a while I thought it was 
> software-related; it "felt" software-related.
> -- 
> Kent
Interesting.  Looking back in my log book I find I installed a new
motherboard and cpu (Albatron KX400-8XV and Athlon XP2000) on Nov. 7th
and kernel-source-0.6.0-test9 on Nov. 9th.   Installed
module-init-install on Nov. 11th as this was needed to load the ehci
module.  The first note of a boot up problem was on Nov. 12th.

Could there be a motherboard problem?  I have used Albatron KX400 series
motherboards in other computers with no problems but, interestingly, I
recall seeing a message regarding an unknown southbridge when booting up
from the bbc-2.1 cd.

> -- 
> To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact 
> listmaster@lists.debian.org

Reply to: