[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: D-link DFE-530tx



On Sun, Nov 02, 2003 at 02:50:46PM +0100, Kurt Sys wrote:
> ScruLoose wrote:
> >On Sat, Nov 01, 2003 at 03:14:56PM +0100, Kurt Sys wrote:
> >>Quoting Rob Weir <rweir@ertius.org>:
> >>
> >>>This usually means the module is already loaded, or in the case of the
> >>>Debian install kernels, that the module is built in.  Have you checked
> >>>"dmesg" to see if your card is already detected?
> >>>     
> >>>
> >>Thanks for your reply (and the replies of others, but no, I didn't check 
> >>'dmesg'
> >>yet. I add here some more output. I upgraded to  kernel 2.4.18 (which is 
> >>on CD1
> >>also), and tried the most obvious possibilities (via-rhine, sundance and 
> >>realtek
> >>modules). I didn't include any of them in the kernel, so they won't be in 
> >>the
> >>kernel, I guess, and they cannot be inserted as a module.
> >>   
> >>
> >
> >I've got the same card, and it gave me a bunch of trouble... I'm not
> >sure how much of what I did is the "right" way (or how much help it'll
> >be to you), but I've got the thing working. 
> >
> >Oh, and just in case they're some help, here are a couple of posts I
> >made while I was trying to figure it out:
> >
> >http://lists.debian.org/debian-user/2003/debian-user-200310/msg06562.html
> >http://lists.debian.org/debian-user/2003/debian-user-200310/msg07243.html
> >
> > 
> >
> 
> As far as I understood well, when you used knoppix, 'eth0' was up, but 
> not really running. What I mean is, the card was found, but it didn't 
> work (you couldn't ping, you couldn't reach a network, ...). It's 
> because if I use Knoppix, it is that way:

Actually, no.  When I used knoppix it Just Worked (tm).

Under debian 2.4.x kernels when I was booting _without_ the "noapic"
parameter, I was getting the situation you describe here.
Under debian _with_ the noapic parameter, I still get that situation if
I for any reason ifconfig eth0 down and then bring it back up. And once
it's screwed up like that, it stays screwed until I reboot.

But if I bring it up with the right settings on the first try (after
booting with noapic) then it works.


> ----- dmesg -----
> [...snip...]
> via-rhine.c:v1.10-LK1.1.19  July-12-2003  Written by Donald Becker
>  http://www.scyld.com/network/via-rhine.html
> eth0: VIA VT6105 Rhine-III at 0xff9ffc00, 00:05:5d:81:f5:0b, IRQ 22.
> eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 45e1.
> [...snip...]
> eth0: Setting full-duplex based on MII #1 link partner capability of 45e1.
> eth0: Reset not complete yet. Trying harder.
> eth0: Setting full-duplex based on MII #1 link partner capability of 45e1.
> -----
> 
> ----- lsmod -----
> [...snip...]
> via-rhine              13968   1
> mii                     2256   0  [via-rhine]
> crc32                   2832   0  [via-rhine]
> [...snip...]
> -----

	Cheers!
-- 
,-------------------------------------------------------------------------.
>   -ScruLoose-   |         Do not meddle in the affairs of wizards       <
>  Please do not  |    for you are crunchy and taste good with ketchup.   <
> reply off-list. |                                                       <
`-------------------------------------------------------------------------'

Attachment: pgpkVsIqamBx3.pgp
Description: PGP signature


Reply to: