[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Apt-get: move from cdrom to online-sources

> > OK, so next I want to get the sudo package and run:
> > 
> >   # apt-get install sudo
> >   Reading Package Lists... Done
> >   Building Dependency Tree... Done
> >   W: Couldn't stat source package list http://ftp.br.debian.org
> >   woody/main Packages
> >   (/var/lib/apt/lists/ftp.br.debian.org_debian_dists_woody_main_binary-i386_Packages)
> >      - stat (2 No such file or directory) 
> >   ... [same for three directories in each of the two source sites
> >        listed in sources list]
> >   W: You may want to run apt-get update to correct these problems
> >   E: Couldn't find package sudo
> > 
> > I don't understand this. Apparently apt-get reads my sources.list, but
> > can't use it. Running apt-get update has the same result. I added
> apt-get update has the *exact* same error?  update should try to go out
> on the network and get the missing package lists from your debian
> mirror.

Well, no, at least not now when I try it. I was only looking at the
end of all the response, for I can't seem to copy/paste from an
xterm. However, this time did an eshell in emacs and saved the buffer
that resulted from the apt-get update to a file. Here is the first few

  Err http://ftp.br.debian.org woody/main Packages
    Could not connect to ( - connect 
	  (111 Connection refused)
  Err http://ftp.br.debian.org woody/main Release
    Could not connect to ( - connect 
	  (111 Connection refused)

In the sources.list, the internet URIs are followed by CDROM URIs:

  rr cdrom://[Debian GNU/Linux 3.0 r1 _Woody_ - Official i386 
    Binary-7 (20021218)] unstable/contrib Packages
    Please use apt-cdrom to make this CD recognized by APT. 
    apt-get update cannot be used to add new CDs

News to me! So instead of apt-get install <package>, I'd use apt-cdrom
install <package>? But I prefer aptitude. Would it therefore be: #
aptitude-cdrom install <package>? 

The intial response suggests to me that I'm misconfigured somehow.



Reply to: