[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't install networking.

On Fri, 31 Oct 2003 22:23:07 -0700, Monique Y. Herman wrote:
>On Sat, 01 Nov 2003 at 02:17 GMT, Mark Healey penned:
>> On Fri, 31 Oct 2003 18:03:59 -0700, Monique Y. Herman wrote:
>>>More pertinently, what part of the general advice given to you several
>>>posts ago frustrated the bejeezus out of you?  Was it the
>>>recommendation to use `uname -a` to find your kernel version?  The
>>>fact that you have to care about kernel versions at all?  The deal
>>>about the modules?
>> It said Linux utonium 2.4.18-bf2.4 [some greek]
>That simply means that you're running the linux kernel, version
>2.4.18-bf2.4, and your machine name is utonium (is this related to the
>powerpuff girls?).


>I can't interpret the greek part since you haven't
>included it, but I'm guessing it probably involved the date, time zone,
>and the architecture of your machine.

It looked like that.

>> The post then said to run "apt-cache search kernel-image-2.4 | more"
>> and then select the apprpriate kernel.
>> There was no output when I ran that.
>I've never used apt-cache, but a quick look at the man page suggests
>that perhaps you hadn't yet generated the cache, so searching on it
>probably wasn't very helpful.  Looks like the original poster assumed
>the cache was already generated.
>> I read further anyway and it says to install the broadcom module which
>> is impossible since there isn't one there.
>Where is "there"?  The interpretation that springs to mind is that you
>searched through the kernel configuration screen using 'make xconfig' or
>similar, but I suspect that's not what you mean.

There was no bcm4400.o in the "net section".

I should mention that I had to download this from Broadcom.  I have a
CD with a source RPM and a .tar.gz.  On an earlier attempt I tried to
compile it from source but after I expanded the .tar.gz I couldn't
extract resulting .tar.  I'd run tar -x bcm4400-2.5.0.tar and nothing.
No disk activity, no expansion, I'd have to control-c out of the

>I haven't installed a debian machine from scratch in quite a while, and
>even when I did, I used what I can only with charity call "obsolete"
>install CDs.  So I'm afraid I can't answer this question for you.  I can
>tell you that when I used these obsolete CDs, they did not have drivers
>for my on-board NIC, so I ended up using a spare $15 (if that) NIC to
>give myself access to the net.  I used that network access to upgrade
>my system to modern components, including a far more recent kernel that
>"knew" about my built-in network card.

I checked my scrounge box and didn't have any.  Something I learned
from my first Redhat attempt is that by the time a piece of hardware
is supported by Linux it is frequently no longer available in the

I'm going to install once again from the "vanilla" CD since the module
doesn't seem to be compiled into the "bf2.4" one as I was told.

Mark Healey

Giving debian a chance.

Reply to: