[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Lots of brokeness in Sid this morning

Derrick 'dman' Hudson wrote:

On Tue, Oct 21, 2003 at 11:31:44AM -0500, Kent West wrote:

| westk[@westek]:/home/westk:> mozilla-thunderbird
| find: /usr/lib/mozilla-thunderbird/startup-hooks.d/*: No such file or | directory | | and then just dies. So I'd say there's still some brokenness in sid's | version. I don't know what the fix is for that.

Just a guess, but try
   # mkdir -p /usr/lib/mozilla-thunderbird/startup-hooks.d
   # chmod o+rx /usr/lib/mozilla-thunderbird
   # chmod o+rx /usr/lib/mozilla-thunderbird/startup-hooks.d


(I haven't looked at thunderbird myself yet, however next time I need
to test something in particular I'll install it)

The directory, or actually a symlink, already exists.
westk[@westek]:/home/westk:> ls -ld /usr/lib/mozilla-thunderbird/startup-hooks.dlrwxrwxrwx 1 root root 44 Oct 21 09:07 /usr/lib/mozilla-thunderbird/startup-hooks.d -> /var/lib/mozilla-thunderbird/startup-hooks.d

And the referenced directory exists:
westk[@westek]:/home/westk:> ls -ld /var/lib/mozilla-thunderbird/startup-hooks.ddrwxr-xr-x 2 root root 1024 Oct 18 06:22 /var/lib/mozilla-thunderbird/startup-hooks.d

But, it's an empty directory:
westk[@westek]:/home/westk:> ls -la /var/lib/mozilla-thunderbird/startup-hooks.d
total 2
drwxr-xr-x    2 root     root         1024 Oct 18 06:22 .
drwxr-xr-x    6 root     root         1024 Oct 21 09:07 ..

But interestingly, you gave me the idea to run it as super-user, so I ran "sudo mozilla-thunderbird". I still got the error, but this time thunderbird started. So I exited out, and then ran it as my normal user, and now it works, and I no longer even get the error message, even though the directory is still empty.

Huh. Go figure.


Reply to: