[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: install

Sidney Brooks wrote:
 I followed the instructions below. When I entered
"linux single" at the boot prompt, I ended up with a
blank screen and frozen computer.

I might add, Debian "potato" didn't work for me in the
graphical mode because it only accepted the lowest
resolution, 640x400 (I think), and everything was so
big that it was useless. With it, I could get into the
text mode which I cannot do with woody.

For the record, RedHat gives me no trouble

I apologise for this very late reply, especially when I see that I replied in this thread earlier because I noticed the MBR offshoot. I wasn't watching the mail in a thread capable reader and had missed the context of your whole message.

I have a SavagePRO on the K133 chipset in a Shuttle XPC. I don't remember it giving me such grief in text mode, but I was not able to use X with Stable(Woody). The "right" driver can be found at Tim Robert's site: http://www.probo.com/timr/savage40.html. Unfortunatly it requires xserver-xfree86 v4.2 which was ithe version in Sarge in June/July 2003. I pinned to get it and discovered that I was better off using Sarge, and then Sid.

You mean Debian "Woody" and not Potato, right? Either way should be the same. I only ask because you mention both and I haven't tried this chipset with Potato.

I am puzzled about your not being able to boot into single user mode. I can (sortof) understand a lockup if you have X configured to start when the system boots all the way but not the lack of text mode. The SavagePRO DDR on the K133 worked just fine for me. If other systems didn't work, I'd wonder if you had some video memory allocated to the chipset and the other settings correct in the BIOS. Since you say RH works on that machine, and text mode seems to be failing you, I'm stumped.

If you are able to get into text mode (even if it's by re-installing) then set gdm/kdm/xdm to not start a graphical login at boot. Once you have that, get the Savage driver from Tim's site and configure X. Test using startx before setting your display manager to auto-start again.

Although one person answered the message below, I
never saw it posted. In case something strange
happened, I am trying it again.

Rodney D. Myers responded to it.


I attempted to install Woody version 3.0. Everything
went smoothly until I tried to use it after the
installation. All I get is a blank screen and a


computer. I think that my problem is a video card


linux does not like, S3 Pro-Savage KM133. Any
suggestions as to how I can make things work. I


use the text mode, therefore I cannpt change any

The questions after this are spot-on. Because you were able to go through the installer, it seems that the comptuer is able to talk to your video chip in text mode. It sounds like the system is trying to start the X server with a display manager and dying.

If you are unable to switch virtual terminals by pressing CTRL-ALT-F[1-5], then the computer is pretty locked up. I don't remember trying the VGA driver for X, and I never experianced a hard lockup like that. At worst X would restart a few times then the config program would run asking me to choose different settings.

Does Ctrl-Alt-F2 not switch you to a workable
text-based console? From there you should be able to repair whatever's wrong.

Otherwise you can, at the "boot:" prompt (assuming
you're using lilo and not grub, etc), enter "linux single" to boot into single-user mode, where you can then repair what's wrong.

Once at a text-based console, the first thing to do is
to disable the automatic startup of X. You're probably using a graphical session manager, either xdm, wdm, kdm, or gdm. There are several ways to do this; probably the way I would do it is to temporarily put the single line "exit 0" as the first executable line in the session manager start-up script. This script will be in "/etc/init.d", and will have a symlink in "/etc/rc2.d". The script in "/etc/init.d" will probably be named "xdm", "wdm". "kdm". or "gdm". The script in "/etc/rc2.d" will have a "S" and a number in front of the script name, like "S99kdm" or "S98gdm". You can disable the graphical session for the current boot only by running this script with the "stop" flag, like so: "/etc/init.d/kdm stop" (which you'll want to do _before_ adding "exit 0" to the script).

Now run "dpkg-reconfigure xserver-xfree86" and play
with the X settings, and then try starting X with "startx". Once you get a working system, you can remove the "exit 0" and then run the script with the "start" option and see if the graphical session manager (GUI logon screen) works.

I hope this gets you running. I feel bad that I missed being able to help out so long ago. I hope you don't mind that I'm CC'ing you incase you have dropped from the list.

Reply to: