[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cannot install perl-doc

Praveen Kallakuri wrote:
> Sorry, but the following packages have unmet dependencies:
>  perl-doc: Depends: perl (>= 5.6.1-8.3) but it is not going to be 
> installed

What does this say on your machine?

  apt-cache policy perl

Mine says:

  Installed: 5.6.1-8.2
  Candidate: 5.6.1-8.3
  Version Table:
     5.6.1-8.3 0
        500 http://security.debian.org stable/updates/main Packages
 *** 5.6.1-8.2 0
        100 /var/lib/dpkg/status
     5.6.1-7 0
        500 http://http.us.debian.org stable/main Packages

This shows that there is a security update for perl and so I am going
to get the version from security and not the version from the main
archive.  It has been updated for a security fix.  My machine's
/etc/apt/sources.list file shows the following two lines, in addition
to others too.

  deb http://gluck.debian.org/debian/ stable main contrib non-free
  deb http://security.debian.org/ stable/updates main

> it says perl-doc depends on perl with version later to 5.6.1-8.3; i
> have perl 5.8 installed. so there shouldn't be any problem, right?
> why does it say "but it is not going... " if the package it depends
> on has the correct installed version?

If you have perl-5.8 installed then that means you are running either
testing or unstable or have installed perl outside of the packaging
system such as through a CPAN or other install.  Of course all of
those are possibilities but I recommend sticking to the packaging
system installation.  perl-5.8 out of testing is perl-5.8.0-19.  That
would certainly meet the dependency of perl-doc that perl be >=
5.6.1-8.3.  If you got the version from testing/unstable then at one
time you modified your /etc/apt/sources.list file to pull from that
location and did the update.

So now this seems really strange.  Installing perl-doc wants perl >=
5.6.1-8.3 so you are using a sources.list line that says any of
security, testing, or unstable as all three of the versions there want
that same dependency.  But in all of those cases the version of perl
in the same depot is fine to go with that and should also be installed
along with perl-doc.  So it is something else.  Knowing where perl is
coming from would be useful and the 'apt-cache policy perl' above
would show that.

At my end of guessing what is wrong there are a number of things that
I might guess.  I say to myself, "What if someone did this?", and
"Perhaps it was that."  Such as let me guess that you held perl at
5.6.1-7 out of stable and then installed perl-5.8 out of CPAN outside
the packaging system.  I have no idea if you did those things but that
would fit this case.  Since apt can't install the perl that goes with
perl-doc because it was held it can't install perl-doc either.  That
is the problem with debugging by mail.  There are so many possible
ways for things to go wrong but in reality it takes only one.

Double check your /etc/apt/sources.list entries and also check what
apt is seeing with apt-cache and the answer will be revealed.  Also,
make sure you have run 'apt-get update' to make sure you have current
package lists.


Attachment: pgpXbvnNHmsBR.pgp
Description: PGP signature

Reply to: