[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

CUPS fails outside of Gimp. HP1200 LJ

My printer stopped printing yesterday and I can't figure out what happened
from debugging output from CUPS.  In most cases there is no apparent
indication of any problem.  What appears logged is cupsysd reporting seeing
a Trailer and EOF, and announcing that the job is complete.  The LaserJet
1200 light will blink for varying amounts of time during the attempted
print, but no output is generated.

The Gimp is the one app which succeeds.  All others tried (LyX, gnumeric,
Galeon, Opera, and most attempts at the console) produce no output.

The few times I see a logged problem noted are when I try different .ppd
files in etc/cups/ppd/ --one contained an error and was unreadable. 
Additionally, there is an occasional inability to read the classes.conf
file; I haven't defined any classes.

I have tried modifying the printer through localhost:631, deleting it and
recreating it, reconfiguring and reinstalling all cups* through
'dpkg-reconfigure' and 'apt-get --reinstall install' ...

The installed packages (all Sid) are 
	cupsys   cupsys-bsd   cupsys-client   cupsys-driver-gimpprint
and there was no recent upgrade leading into this problem.

Does anyone have suggestions for me to try??  I'd like to purge the packages
and reinstall, but am uncertain how to do that while leaving all the
other dependent packages alone.  Or does 'apt-get --reinstall install'
overwrite existing files?

Are there helper apps (gs, for instance) which are known to be problematic?

Many thanks for any thoughts.


In a completely rational society, the best of us would aspire to be 
_teachers_ and the rest of us would have to settle for something less, 
because passing civilization along from one generation to the next 
ought to be the highest honor and the highest responsibility anyone 
could have.     - Lee Iacocca

Reply to: