[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Solved Re: cdrecord suddenly doesn't allow burning



On Thu, Aug 07, 2003 at 09:36:11AM -0700, Joris Huizer wrote:
> --- Pigeon <jah.pigeon@ukonline.co.uk> wrote:
> > 
> >   chmod 4710 /usr/bin/cdrecord.*
> >   chmod 755 /usr/bin/cdrecord
> 
> Thanks, those two commands solved the problems :-)

Cool.

> I don't know the syntax chmod 4710 /usr/bin/cdrecord.*
> ... well I'll have a look at the man page of chmod to
> see what i means exactly :-)

It's a little terse... permit me to waffle :-)

The number 4710 is an octal number, ie. in base eight; each of its
digits can have a value from 0 to 7 (decimal) which corresponds to
000 to 111 (binary) - ie. three bits per octal digit. The whole thing,
4 octal digits, is therefore a 12-bit binary number:

    4       7       1       0    octal
  1 0 0   1 1 1   0 0 1   0 0 0  binary
  
which is easy to convert in your head. It also fits neatly into the
12-bit file attributes value that chmod modifies:

           4               7       1       0    octal
    1      0      0      1 1 1   0 0 1   0 0 0  binary
  setuid setgid sticky   r w x   r w x   r w x  file attributes
     "special" flags     user    group   other

or

  setuid, user: read/write/execute, group: execute-only, other: no access
  
or

  -rws--x---

The advantage of this method is that when making major changes to a
file's permissions, and/or wanting to make sure that you wipe out any
possibly untoward remnants of previous permissions, it saves a lot of
typing over the chmod ug plus this wibble minus that dance. After a
while, values like 4710, 755, 660 and suchlike become instinctive...
having to set rw-rw-rw- is a bit dead and chewed though :-)

> By the way, I tried to be sure cd ripping works ok;
> anyway
>   cdda2wav -D /dev/cdrom -B
> doesn't give me any problems :-)

OOI is your cdda2wav setuid root? Mine is; this overcomes the problem
Andreas mentioned, but I can't remember whether I set it that way or
Debian did...

> Thank you for all your advice,

No prob. I take it you meant to post this to the list, rather than to
me only? :-)

-- 
Pigeon

Be kind to pigeons
Get my GPG key here: http://pgp.mit.edu:11371/pks/lookup?op=get&search=0x21C61F7F

Attachment: pgpR3WTMSC2ad.pgp
Description: PGP signature


Reply to: