[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Woody, KDE startup does not go past "Peripherals" phase


I have a similar experience with Woody on a laptop.  If I turn off the 
sound daemon <booting into a plain X session and then with an editor 
modifying the KDE config files> I can then get into KDE.  In the KDE 
control center the aRts should be off.  This did it for me.  Interestingly 
Knoppix 3.2 recognizes the sound card but fails on modprobe 

You can go to the .ked/share/config/kcmartsrc file and set 
"StartServer=false" <quotes are mine> and see if that helps...


On Wed, 6 Aug 2003, Harshwardhan Nagaonkar wrote:

> Hello all,
>     This problem has me perplexed. I have a machine which I have run in 
> the past with Debian Testing (Sarge). Everything is great. With the 
> progression to libc6.3 in Testing, one very important application broke 
> (CAD software). Hence, I now have to go back to Stable (or Woody, more 
> correctly, since I won't be able to use Sarge when it goes stable due to 
> libc) to make it work.
>     Whenever I need to install a machine, it is always stable. I get the 
> base stuff, then change the sources.list and upgrade before I start 
> getting anything serious like X/Gnome/KDE. This time I got X first, to 
> make sure that it would work. I ran into the problem that the XFree86 in 
> Woody does not recognize a particular variant of the ATI Rage128 Pro 
> Chipset (the ATI Rage128 Pro Ultra TF). It list all sorts of 
> combinations like Rage128 Pro SD/DE and other 2 letter combos :) but not 
> TF :(
>     Well I got it to work with the 'vesa' driver, so its slow but working.
>     Next I got KDE / Gnome / Blackbox packages from apt. I got 'kdm' 
> first and tried to log on into KDE. Then I said, maybe its kdm, so I 
> installed and used gdm. Similarly for xdm also. They all used to start 
> KDE, then go up to the "Detecting Peripherals" phase in the little 
> startup screen and then the screen used to flash and go back to 
> xdm/gdm/kdm. I even did the worst by logging in as root to try and see 
> if it had anything to do with my priveleges, but to no avail.
>     I checked the logs against a working Sarge machine, there was 
> nothing radically different in them, except that X used to get killed in 
> my Woody machine, hence I think it used to dump me back into the login 
> screen.
>     I've tried installing all known packages with even the work KDE in 
> them! I've also re-installed the whole machine once. I'd appreciate any 
> help in this, I couldn't find any bug-reports or mailing list emails 
> that referenced this problem in particular...

Luc Lefebvre

In the beginner's mind there are many possibilities,
in the expert's mind there are few.			<Shunryu Suzuki>

Key fingerprint = D2E5 5E35 B910 6F4E 0242  EC63 0FD9 96D0 C7F4 784E

Reply to: