[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Realtek 8139 install prob solved! [was: more install problems]

On Tuesday 05 August 2003 17:23, Greg Folkert wrote:
> Okay now, SINCE you went through a ton of trials and
> tribulations...
> Time to Write up a Good Summary with a few key details [...]

There is not much to it:

Trying to install Woody from CD set onto a second-hand IBM Thinkpad 
570 notebook.  Pcmcia NIC with Realtek 8139 chipset (mine was called 
'Net-Lynx 428X', but I gather there are others).

Install Knoppix.  Knoppix is a bootable CD Debian-based disto on a 
single compressed CD.  It has excellent hardware recognition, and 
basically sets everything up for you.

This card was identified by manufacturer number and model at hardware 
identification but it seemed the drivers included with Woody 
distribution CDs do not work with it.  I found it easy to omit 
important hardware support during the install.  PCMCIA and hotplug 
were definitely missing from some of my attempts.  In the end I felt 
I had tried everything, and was getting nowhere.  I discovered that 
Mandrake and Morphix (a variant of Knoppix) both started the NIC 
automatically early in their installs.  Yes, if I installed Linux 
once, I installed it ten times...  So, I decided to try Knoppix.  I 
have broadband, so the download was only 3 hours or so.  Burned the 
iso onto a CD, and booted it in the Thinkpad.  Everything worked as 
if by magic.  To transfer the installed system onto the hard drive, I 
followed the instructions at 
This uses a slightly primitive install script (which requires a single 
root partition of 2.2GB IIRC.)  But it works.  You only need to tweak 
the network settings and you have a working Debian with an impressive 
lot of software already in place.

Consensus was that driver 8139too should work.  This driver is loaded 
as a module in the 'standard' Woody, but built into the kernel in the 
"bf2.4" version.  I had chosen the latter in order to get the 2.4 
kernel and to be able to use a journalling fs.  I installed both 
versions more than once, and never got the NIC active.  Errors were 
always of the "no device" kind.  

I also tried to compile the driver provided by the manufacturer on a 
floppy with the card, without success.  I installed the alternative 
kernel 2.4.18-686 from the CD set, and downloaded and compiled the 
version of the '8139too' driver from the Realtek website (this 
required a couple of edits to the Makefile provided).  This driver 
did not work for me either.

First, I should say that it is altogether possible that the problem is 
not with the driver.  I am quite capable of leaving something else 
out or malconfigured.  So, YMMV.  

That said, based on my experience, any newbie or intermediate user 
like me is advised not to waste time if the Realtek 8139 is not 
recognised and installed during install of Woody.  Make sure hotplug 
and pcmcia stuff is all in place, and if it still doesn't work, get 
Knoppix.  Whatever the cause of the problem, a working system with a 
live network connection is a better medium for learning more about 
Linux than one you feel may never connect.  Experts can make their 
own mind up how much time to invest -- but I imagine experts don't 
get so deep into the mud in the first place...

To everyone who helped.  This is a _great_ community.  I learned a 


Reply to: