[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Lexmark USB Printer



On Mon, 2003-07-21 at 03:15, ghwb wrote:
> Tinus Kotzé wrote:
> > Good day
> > I am setting up my first USB device. It is the Lexmark z25 printer.
> > Under kprinter(add local printer) it is listed under the usb devices as
> > a lexmark z25_z35 printer. Everything seems fine, accept that if I print
> > a page, it never seems to appear in the job queue of cups. In console I
> > tried echo foo.txt > /dev/usb/lp0 and it just gives me the prompt again,
> > but with lp[1..x] it gives an error of no device so I am concluding that
> > the device is on lp0. I am running debian unstable kernel 2.4.20 and is
> > using cups as interface for my printing.
> > 
> > Can anybody help me please? I tried googling but couldn;t find an
> > answer, except that the printer may not be usable under linux which I
> > will not accept ;-)
> > 
> > I have also tried the drivers from lexmark's site, but it seems to be
> > rpm based and I am not clued up enough in linux to work around the
> > script and use alien to try install the rpm.
> > 
> > Regards
> > Tinus
> > 
> > 
> 
> You should be able to apt-get rpm to install rpm, then use the lexmark 
> rpm driver (with --nodeps to force installation over objections), then 
> check linuxprinting.org to see if there is a lexmark-foomatic-kit for 
> your printer, and check the lexmark mail list on linuxprinting.org. 
> After tons of effort, I finally have my z32 working.  But, it's not 
> perfect and I still have to do some printing from M$.
> 
Thanx for the advice. The problem is that the driver from lexmark is a 
script file combined with the gzipped rpm and I don't think I can add the 
paramater. I will try later today when I have time to maybe fool the 
program with a link.

Regards
Tinus



Reply to: