[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ugly fonts in X apps (xclock & xbuffy)

Op do 03-07-2003, om 17:42 schreef nori heikkinen:
> suddenly, my fonts in X are all weird.  gtk stuff is still fine, but
> xbuffy and xclock have been beaten with an ugly stick.  i posted once
> on this about 10 months ago[1], and didn't receive an answer ... but i
> fixed it, and don't remember how i did it (this time i'll be sure to
> write it down!)  a screenshot i took around that time (it looks the
> same now) is here: http://www.maenad.net/geek/xbuffy-ugly.jpg
> searching list archives also turned up martin having the same
> problem[2].  following that thread through didn't turn up much,
> either.
> i have FontPaths in my /etc/X11/XF86Config-4:
>         FontPath        "unix/:7100"                    # local font server
>         FontPath        "/usr/lib/X11/fonts/Type1"
>         FontPath        "/usr/lib/X11/fonts/CID"
>         FontPath        "/usr/lib/X11/fonts/Speedo"
>         FontPath        "/usr/lib/X11/fonts/misc"
>         FontPath        "/usr/lib/X11/fonts/cyrillic"
>         FontPath        "/usr/lib/X11/fonts/100dpi"
>         FontPath        "/usr/lib/X11/fonts/75dpi"
> I don't think I run xfs, but I'm not sure -- but either way,
> configuring my 'catalogue' line in /etc/X11/fs/config as suggested in
> [3] didn't do anything.  Ron seemed to fix it by patching together an
> old XF96Config-4 file, but I still have all my fontpaths ...
> I'm not sure what's wrong, but it's sure ugly!
> help?
> </nori>


i had some font problems too a while ago. I posted my sollution here 
and it's posted again in this email. i don't use a font server so i 
commented that out in my xconfig. What i did for non gtk / kde stuff
is make an ~/.Xdefaults file with these settings. 
  *font:  -misc-fixed-medium-r-normal-*-13-120-75-75-c-70-iso8859-15
  *VT100*font2: -misc-fixed-medium-r-normal-*-*-70-*-*-c-*-iso8859-15
  *VT100*font3: -misc-fixed-medium-r-normal-*-*-100-*-*-c-*-iso8859-15
  *VT100*font4: -misc-fixed-medium-r-normal-*-*-120-*-*-c-*-iso8859-15
  *VT100*font5: -misc-fixed-medium-r-normal-*-*-140-*-*-c-*-iso8859-15
  *VT100*font6: -misc-fixed-medium-r-normal-*-*-200-*-*-c-*-iso8859-15
  xterm*visualBell: true
  xterm*foreground: black
  xterm*scrollBar: true

After this, my fonts where fine.

Try this and see what happens.

============== previous post from i don't know when ==============


i solved problem 2 also.  It was not that straightforward since is use
fluxbox with KDE and GNOME programs.
First of all make sure the FontPath
in the /etc/X11/XF86Config-4 file are correct. 

Section "Files"
#FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"


I don't use a fontserver so /etc/X11/fs/config is of no use of me.
If you do have a font server, make sure you edit this file
and make sure the catalogue is correct. You can then
start an x session and check with xlsfonts what fonts are
known to the X. If you can see the font you want to use,
you known the fonts can be seen by X.
I wanted to change the fonts of 2 apps that i use a lot:
xterm and evolution.
For xterm, i made a ~/.Xdefaults file which has this

*font:  -misc-fixed-medium-r-normal-*-13-120-75-75-c-70-iso8859-15
*VT100*font2: -misc-fixed-medium-r-normal-*-*-70-*-*-c-*-iso8859-15
*VT100*font3: -misc-fixed-medium-r-normal-*-*-100-*-*-c-*-iso8859-15
*VT100*font4: -misc-fixed-medium-r-normal-*-*-120-*-*-c-*-iso8859-15
*VT100*font5: -misc-fixed-medium-r-normal-*-*-140-*-*-c-*-iso8859-15
*VT100*font6: -misc-fixed-medium-r-normal-*-*-200-*-*-c-*-iso8859-15
xterm*visualBell: true
xterm*foreground: black
xterm*scrollBar: true

I found the correct fonts by running the Xfontsel program
and setting the correct parameters for a font.
Xterm then displays the correct fonts and I can then use 
shift "-" and shift "+" to switch the fonts. Pretty cool.
Next i looked to change the base font evolution uses. The
preferences allow to change the font of a message or the 
font used to print but not the font for the inbox or the 

I found a post somewhere on the next in regards to a 
gtkrc problem and it solved mine too. Make a ~/.gtkrc file
and put this in:

style "gtk-default-iso-8859-15" { 
fontset = "-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-1,\ 

class "GtkWidget" style "gtk-default-iso-8859-15" 
Change the fonts to whatever you like as fonts and bingo,
Evolution now uses a smaller font that allows me to have
more info on the screen. 
Hopes this helps other people struggling with fonts.


=END========== previous post from i don't know when ==============

Reply to: