[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ugly fonts in X apps (xclock & xbuffy)

suddenly, my fonts in X are all weird.  gtk stuff is still fine, but
xbuffy and xclock have been beaten with an ugly stick.  i posted once
on this about 10 months ago[1], and didn't receive an answer ... but i
fixed it, and don't remember how i did it (this time i'll be sure to
write it down!)  a screenshot i took around that time (it looks the
same now) is here: http://www.maenad.net/geek/xbuffy-ugly.jpg

searching list archives also turned up martin having the same
problem[2].  following that thread through didn't turn up much,

i have FontPaths in my /etc/X11/XF86Config-4:

        FontPath        "unix/:7100"                    # local font server
        FontPath        "/usr/lib/X11/fonts/Type1"
        FontPath        "/usr/lib/X11/fonts/CID"
        FontPath        "/usr/lib/X11/fonts/Speedo"
        FontPath        "/usr/lib/X11/fonts/misc"
        FontPath        "/usr/lib/X11/fonts/cyrillic"
        FontPath        "/usr/lib/X11/fonts/100dpi"
        FontPath        "/usr/lib/X11/fonts/75dpi"

I don't think I run xfs, but I'm not sure -- but either way,
configuring my 'catalogue' line in /etc/X11/fs/config as suggested in
[3] didn't do anything.  Ron seemed to fix it by patching together an
old XF96Config-4 file, but I still have all my fontpaths ...

I'm not sure what's wrong, but it's sure ugly!



[1] http://lists.debian.org/debian-user/2002/debian-user-200208/msg04342.html
[2] http://lists.debian.org/debian-user/2003/debian-user-200305/msg00350.html
[3] http://lists.debian.org/debian-user/2003/debian-user-200305/msg00243.html

    .~.      nori @ sccs.swarthmore.edu
    /V\  http://www.sccs.swarthmore.edu/~nori/jnl/
   // \\          @ maenad.net
  /(   )\       www.maenad.net
            get my (*new*) key here:
      (please *remove* old key 11e031f1!)

Reply to: