[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

xosd: can't get it to work....

i've just found out xosd.
i installed it from source (http://www.ignavus.net/xosd-2.2.2.tar.gz).

but when i run the example from http://ldots.org/xosd-guide/osd_cat.html
i get "Error initializing osd: Default font not found"

$ FONT="-adobe-helvetica-bold-*-*-*-34-*-*-*-*-*-*-*"
$ tail -f /var/log/messages | osd_cat --font=$FONT --shadow=2
Error initializing osd: Default font not found

when i run src/testprog i get the same error...

but when i run this program i get : could not create "osd"
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
#include <xosd.h>

int main (int argc, char *argv[])
 xosd *osd;

 osd = xosd_create (2);
 if (osd == NULL)
     perror ("Could not create \"osd\"");
     exit (1);

xosd_set_font (osd, "-adobe-helvetica-bold-r-normal-*-*-320-*-*-p-*-iso8859-1"

 xosd_set_shadow_offset (osd, 2);
 xosd_set_colour (osd, "#494066");
 xosd_set_outline_offset(osd, 2);
 xosd_set_outline_colour(osd, "black");

 xosd_set_pos (osd, XOSD_bottom);
 xosd_set_vertical_offset (osd, 48);

 xosd_set_align (osd, XOSD_right);
 xosd_set_horizontal_offset (osd, 48);

 xosd_display (osd, 0, XOSD_string, "You have been R00ted");

 sleep (8);
 xosd_destroy (osd);
 exit (0);

how can i get osd/osd_cat to work? To just show something...

Joel Alexandre

Reply to: