[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

2.4.21 not compiling

Hi all,
I'm currently running Debian sarge with:
syner@Zion:~$ apt-show-versions | grep gcc
gcc-3.3/testing uptodate 1:3.3-2
gcc-2.95/testing uptodate 1:2.95.4-17
gcc-3.3-base 1:3.3-3 newer than version in archive
gcc/testing uptodate 3:3.3-1
libgcc1 1:3.3-3 newer than version in archive
showing I have gcc3.3 and gcc2.95 installed.
I patched my 2.4.20 kernel source tree (/usr/src/linux, or /usr/src/linux-2.4.20) with the 2.4.21 patch
by issuing:
gunzip -c | patch -p0
I also did mv linux-2.4.20 linux 2.4.21 , and pointed the symlink linux to the now-renamed linux-2.4.21..
After make menuconfig, I was aware of the problems gcc3.3 was having compiling newer 2.4.x kernels.
So, in /usr/src/linux/Makefile, i replaced the 2 instances of gcc with gcc-2.95 .. next i proceeded to do:
make dep && make clean && make && make install && make modules && make modules_install && depmod -a
Although, I kept getting all these warnings such as:
/usr/src/linux-2.4.21/include/linux/modules/ide-iops.ver:39: warning: `__ver_eighty_ninty_three' redefined
/usr/src/linux-2.4.21/include/linux/modules/ide-features.ver:9: warning: this is the locations of the previous definition
+ many other similar warnings..
After I let this compile run, I checked / , and saw that the kernel had not in fact been updated like it was supposed to (before, it installed it to / for me, then pointed the vmlinuz to the new kernel, and vmlinuz.old to the old kernel all automatically)...
What am I missing here?
Thanks a heap.

Reply to: